Java程序练习-Spell checker

Spell checker

时间限制: 2000ms内存限制: 65536kB
描述
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

输入
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

输出
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
样例输入
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
样例输出
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
参考代码

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Iterator;
import java.util.List;
public class Main {
	public static List<String> list_dict = new ArrayList<String>();
	public static void main(String[] args) throws Exception {
		BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
		String word = new String();
		while(true){
			word = cin.readLine();
			if(word.equals("#"))
				break;
			list_dict.add(word);
		}
		while(true){
			word = cin.readLine();
			if(word.equals("#"))
				break;
			if(find(word)){
				System.out.println(word+" is correct");
			}else{
				similar(word);
			}
		}
	}
	private static void similar(String word) {
		System.out.print(word+":");
		Iterator<String> it = list_dict.iterator();
		int word_len = word.length();
		while(it.hasNext()){
			String sw = it.next();
			int sw_len = sw.length();
			int p = 0;
			if(sw_len == word_len){
				p = comp_1(word,sw);
				if(p == 1)
					System.out.print(" "+sw);
			}else if(sw_len == word_len - 1){
				p = comp_2(word,sw);
				if(p == 1)
					System.out.print(" "+sw);
			}else if(sw_len == word_len + 1){
				p = comp_3(word,sw);
				if(p == 1)
					System.out.print(" "+sw);
			}
		}
		System.out.println();
	}
	private static int comp_3(String word, String sw) {
		int p = 0;
		int j = 0;
		for(int i = 0;i < sw.length()&&j < word.length();){
			if(word.charAt(j) != sw.charAt(i)){
				i ++;
			}else{
				j ++;
				i ++;
				p ++;
			}
		}
		return sw.length() - p;
	}
	private static int comp_2(String word, String sw) {
		int p = 0;
		int j = 0;
		for(int i = 0;i < word.length()&&j < sw.length();){
			if(word.charAt(i) != sw.charAt(j)){
				i ++;
			}else{
				j ++;
				i ++;
				p ++;
			}
		}
		return word.length() - p;
	}
	private static int comp_1(String word, String sw) {
		int p = 0;
		for(int i = 0;i < word.length();++ i){
			if(word.charAt(i) != sw.charAt(i))
				p ++;
			if(p > 1)
				break;
		}
		return p;
	}
	private static boolean find(String word) {
		Iterator<String> it = list_dict.iterator();
		while(it.hasNext()){
			if(word.equals(it.next()))
				return true;
		}
		return false;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值