HDU1003——Max Sum(DP)

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 



分析:


听说这是DP、我没研究过DP题目、这道题按照自己思路写的、中间有点小卡壳、看

了一些博客、借鉴了一下。听说这是DP的入门级别的题。如果各个子问题不是独立

的,不同的子问题的个数只是多项式量级,如果我们能够保存已经解决的子问题的答

案,而在需要的时候再找出已求得的答案,这样就可以避免大量的重复计算。由此而

来的基本思路是,用一个表记录所有已解决的子问题的答案,不管该问题以后是否被

用到,只要它被计算过,就将其结果填入表中——from LCY


——>就是总是把当前最大的数记录下来、然后扫描一遍。




#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int n,t;
int i,j;
int start,end;
int a[100007];
int w=1;
int f(int p)
{
    int max,ls,le;
    int sum=max=-99999;
    for(int i=0; i<p; i++)
    {
        if(sum<0)
        {
            if(a[i]>sum)
            {
                sum=a[i];
                ls=le=i;
                if(sum>max)
                {
                    max=sum;
                    start=ls;
                    end=le;
                }
            }
        }
        else
        {
            sum+=a[i];
            le=i;
            if(sum>max)
            {
                max=sum;
                start=ls;
                end=le;
            }
        }
    }
    return max;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        int r=f(n);
        printf("Case %d:\n",w++);
        printf("%d %d %d\n",r,start+1,end+1);
        if(t)
            printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值