SGU107——987654321 problem

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321. 

Input

Input contains integer number N (1<=N<=106)

Output

Write answer to the output.

Sample Input

8

Sample Output

0

 

 

简单数学,题目说,一个数字n、找n*n结果末尾是987654321的数。

 

先傻瓜式搜索,发现8位以下没有符合要求的;9位有4个,10位以上根据数学排列知识就搞定了。

 

最近在搞SGU,先从简单题目入手,碰到什么算法就搞什么算法。

 

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int main()
{
//    for(int i=0;i<99999999;i++)
//    if(i*i==987654321)
//    printf("%d\n",i);
//    for(long long i=sqrt(987654321.0);i<=999999999;++i)
//        if( i*i%1000000000 == 987654321 )
//            printf("%d\n",i);
//}
//    111111111
//    119357639
//    380642361
//    388888889
//    611111111
//    619357639
//    880642361
//    888888889

    int n;
    while (scanf("%d",&n)!=EOF)
    {
        if (n<=8)
            printf("0\n");
        else if (n==9)
            printf("8\n");
        else
        {
            printf("72");
            for (int i=0;i<n-10;++i)
                printf("0");
                printf("\n");
        }
    }

}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值