SGU113—— Nearly prime numbers

Nearly prime number is an integer positive number for which it is possible to find such primes P1 and P2 that given number is equal to P1*P2. There is given a sequence on N integer positive numbers, you are to write a program that prints “Yes” if given number is nearly prime and “No” otherwise.

Input

Input file consists of N+1 numbers. First is positive integerN (1£N£10). NextN numbers followed byN. Each number is not greater than 109. All numbers separated by whitespace(s).

Output

Write a line in output file for each number of given sequence. Write “Yes” in it if given number is nearly prime and “No” in other case.

Sample Input

1
6

Sample Output

YES

 

先来复习一下筛法求素数相关知识:

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int vis[9999];
void isprime(int n)
{

    int k=sqrt(n+0.5);
    for(int i=2; i<=k; i++)
    {
        if(!vis[i])
            for(int j=i*i; j<=n; j+=i)
                vis[j]=1;
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        vis[0]=1,vis[1]=1;
        isprime(n);
        for(int i=0; i<=n; i++)
        {
            if(!vis[i])
                printf("%d ",i);
        }
    }
    return 0;
}


 

对于给定的数据很大、需用筛法素数打表

那筛法求素数对该题目有什么作用呢?没啥关系。。只不过看到素数就想到了筛法求素数  ^-^

 

 

上述题目题意为给出一个数,让你判断这个数是否为Nearly prime number,Nearly prime number的定义是,这个数能被2个素数相乘求得。

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
bool prime(int p)
{
    int w=0;
    int k=sqrt(p*1.0);
    for(int i=2; i<=k; i++)
        if(p%i==0)
        {
            w=1;
            break;
        }
    if(w==1)
        return 0;
    else
        return 1;
}
bool f(int n)
{
    int f=0;
    for(int i=2; i<=sqrt(n*1.0); i++)
    {
        if(prime(i))
        {
            if(n%i==0)//确保n/i为整数(能被整除)
            {
                if(prime(n/i))
                {
                    f=1;
                    break;
                }
            }

        }
    }
    if(f==1)
        return true;
    else
        return false;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(f(n))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值