SGU130-circle

 

130. Circle

time limit per test: 0.5 sec.
memory limit per test: 4096 KB

On a circle border there are 2k different points A1, A2, ..., A2k, located contiguously. These points connect k chords so that each of points A1, A2, ..., A2k is the end point of one chord. Chords divide the circle into parts. You have to find N - the number of different ways to connect the points so that the circle is broken into minimal possible amount of parts P.

Input

The first line contains the integer k (1 <= k <= 30).

Output

The first line should contain two numbers N and P delimited by space.

Sample Input

2

Sample Output

2 3



 

 

题意是说有一个圆、给你2k个点,让你连接这些点的弦最少能把这个圆划分为几块、并且求出其方法数。

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int main()
{
    int i,j,n;
    long long D[31];
    D[0]=1;
    D[1]=1;
    D[2]=2;
    //画一条弦,则圆被分成两部分,两部分可以各自看成点数比较少的圆,
    //用两部分分割方法数相乘。以一点为这条弦的一端,枚举另一端求和。
    for(i=3; i<=30; i++)
    {
        D[i]=0;
        for(j=1; j<=i; j++)
            D[i]+=D[j-1]*D[i-j];
    }
    while(cin>>n)
    {
        cout<<D[n]<<" "<<n+1<<endl;
    }
    return 0;
}


 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值