HDU - 3605 Escape(二分图多重匹配)

2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.

Input

More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000

Output

Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.

Sample Input

1 1
1
1

2 2
1 0
1 0
1 1

Sample Output

YES
NO

 

二分图多重匹配裸题,也是用匈牙利算法,唯一变形的是要记下限制集合中元素i(假设他最多可以同时与另一集合中a[i]个元素匹配),那么macth[i][j]代表的是与i第j个匹配的元素。

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int N = 1e5+10;
int n,m;
int link[N][15],match[15][N],vlink[15],a[15];
bool vis[N];
bool dfs(int u)
{
	for(int v=1;v<=m;v++)
	{
		if(!vis[v]&&link[u][v])
		{
			vis[v]=1;
			if(vlink[v]<a[v])
			{
				match[v][++vlink[v]]=u;
				return 1;
			}
			for(int i=1;i<=a[v];i++)
			{
				if(dfs(match[v][i]))
				{
					match[v][i]=u;
					return 1;	
				}	
			}
		}
	
	}
	return 0;
}
bool mul_match()
{
	for(int i=0;i<=m;i++)
		vlink[i]=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
			vis[j]=0;
		if(!dfs(i)) return 0;
	}
	return 1;
}
int main(void)
{
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)		
				scanf("%d",&link[i][j]);
		for(int i=1;i<=m;i++)
			scanf("%d",&a[i]);
		if(mul_match())
			printf("YES\n");
		else printf("NO\n");
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值