toj1263 Substrings

1263.   Substrings
Time Limit: 1.0 Seconds    Memory Limit:65536K
Total Runs: 3276    Accepted Runs:914



You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.


Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 ≤ n ≤ 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.


Output

There should be one line per test case containing the length of the largest string found.


Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid


Sample Output

2
2 


Source: Iran 2002 - Tehran Preliminary
水题,没什么意思.看看我翔一般的代码...
/*
    <span style="font-family:Times New Roman;"><span style="color:red;"><strong>Accepted</strong></span></span>
    <span style="font-family:Times New Roman;"><span style="color:green;">Time: </span>0.00 sec.    <span style="color:green;">Memory: </span>868 K. </span>
*/
#include <cstdio>
#include <cstring>
#include <cstdlib>

const int MAX = 128;
char str[MAX][MAX];
char sub[MAX];
int ans, subLen, n;

int cmp(const void* ele1, const void* ele2) {
	char* str1 = (char*)ele1, *str2 = (char*)ele2;
	return strlen(str1)-strlen(str2);
}

inline char* getSub(int l, int r) {
	subLen = 0;
	for (int i = l; i <= r; ++i) {
		sub[subLen++] = str[0][i];
	}
	sub[subLen] = '\0';
	return sub;
}

bool yes(void) {
	bool ok;
	int end, len;
	for (int i = 1; i < n; ++i) {
		//printf("check %s & %s...", str[i], sub);
		ok = false;
		len = strlen(str[i]);
		end = len - subLen + 2;
		for (int j = 0; j < end; ++j) {
			bool flag = true;
			for (int k = 0; k < subLen; ++k) {
				if (sub[k] != str[i][j+k]) {
					flag = false;
					break;
				}
			}
			if (flag) {
				ok = true;
				break;
			}
		}
		if (ok) continue;

		for (int j = len-1; j >= subLen-1; --j) {
			bool flag = true;
			for (int k = 0; k < subLen; ++k) {
				if (sub[k] != str[i][j-k]) {
					flag = false;
					break;
				}
			}
			if (flag) {
				ok = true;
				break;
			}
		}
		if (!ok) return false;
		//printf("ok!\n");
	}
	return true;
}

int main() {
	int T;
	scanf(" %d", &T);
	while (T--) {
		scanf(" %d", &n);
		for (int i = 0; i < n; ++i) scanf(" %s", str[i]);
		
		qsort(str, n, sizeof(char)*MAX, cmp);
		
		int len = strlen(str[0]);
		ans = 0;
		for (int i = 0; i < len; ++i) {
			for (int j = i; j < len; ++j) {
				if (j-i+1 <= ans) continue;
				getSub(i, j);
				//printf("sub = %s\n", sub);getchar();
				if (yes()) ans = j-i+1;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值