toj3259[Mysterious Numbers]埃式筛法

3259.   Mysterious Number
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1267    Accepted Runs: 400



Mysterious Number refers to a number which can be divisible by the number of distinct factors that it has. For instance, 1 (1 factor), 12 (6 factors) and 9 (3 factors) are Mysterious Numbers, but 7(2 factors) or 16 (5 factors) are not.

Given two integers low and high, please calculate the number of Mysterious Numbers between low and high, inclusive.

Input

For each test case, there are two integers low and high in one line separated by spaces.1 ≤ lowhigh ≤ 1,000,000

Output

Print out the number of Mysterious Numbers between low and high, inclusive.

Sample Input

1 10
10 15

Sample Output

4
1

Author: WTommy



Source: TJU Team Selection Contest 2009 (4)

Submit   List   Runs   Forum   Statistics
题目大意是有一种数称为"神秘数", 特征是可以被自己约数的个数整除.比如9有1,3,9三个约数,约数个数为3,而9又能被3整除,所以9是神秘数.又如12有6个约数,12可以被6整除,那12也是神秘数.7有2个约数,但7不能被2整除,所以不是神秘数.
输入给出上下限low, high让你求[low,high]区间有多少个"神秘数".
我靠, 这题搁以前我一定枚举.但是.....呃.....呃..
好吧啊,这题就是埃式筛法.
两个循环可以求出1~100万所有数的约数个数.然后可以dp加速一下.转移
dp[i] = { dp[i-1], i不是神秘数
            { dp[i-1]+1, i是神秘数
然后每次询问low,high.输出dp[high] - dp[low-1]即可.
细节注意:0和1的约数个数处理.
0'00.08"8672K 

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAX = 1000000+1111;
int a[MAX] = {0,1};
int dp[MAX] = {0};
int main() {
	fill(a+2, a+MAX, 2);
	int i, j;
    for (i = 2; i < (MAX>>1); ++i)
        for (j = 2; i * j < MAX; ++j) {
            ++a[i*j];
        }
    //printf("%d\n", a[57896]); //57896 have 8 primes~
	for (i = 1; i < MAX; ++i) {
        dp[i] = dp[i-1] + (i % a[i] ? 0 : 1);
	}
	int low, high;
	while (~scanf(" %d %d", &low, &high)) {
		printf("%d\n", dp[high] - dp[low-1]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值