HDU 5818 模拟

Joint Stacks

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



Problem Description
A stack is a data structure in which all insertions and deletions of entries are made at one end, called the "top" of the stack. The last entry which is inserted is the first one that will be removed. In another word, the operations perform in a Last-In-First-Out (LIFO) manner.
A mergeable stack is a stack with "merge" operation. There are three kinds of operation as follows:

- push A x: insert x into stack A
- pop A: remove the top element of stack A
- merge A B: merge stack A and B

After an operation "merge A B", stack A will obtain all elements that A and B contained before, and B will become empty. The elements in the new stack are rearranged according to the time when they were pushed, just like repeating their "push" operations in one stack. See the sample input/output for further explanation.
Given two mergeable stacks A and B, implement operations mentioned above.
 

Input
There are multiple test cases. For each case, the first line contains an integer N(0<N105) , indicating the number of operations. The next N lines, each contain an instruction "push", "pop" or "merge". The elements of stacks are 32-bit integers. Both A and B are empty initially, and it is guaranteed that "pop" operation would not be performed to an empty stack. N = 0 indicates the end of input.
 

Output
For each case, print a line "Case #t:", where t is the case number (starting from 1). For each "pop" operation, output the element that is popped, in a single line.
 

Sample Input
  
  
4 push A 1 push A 2 pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge A B pop A pop A pop A 9 push A 0 push A 1 push B 3 pop A push A 2 merge B A pop B pop B pop B 0
 

Sample Output
  
  
Case #1: 2 1 Case #2: 1 2 3 0 Case #3: 1 2 3 0
题意:给你两个栈,push操作是压入,pop是弹出栈顶并输出,merge是将后面的栈合并到前面的栈,并且按压入时间排序。
题解:前两个仅仅需要模拟就行了,主要是解决merge,倒过来倒过去,很容易超时,可以定义now为A所属的栈,!now为B所属的栈,那么将元素少的栈合并到元素多的栈里,如果merge A B的时候B的元素多,那么我们把A中的倒入B中,now取反即可。用结构体保存时间。
官方题解: 比较简单巧妙的一个做法是引入一个新的栈C,每次合并的时候就把A和B合并到C上,然后把A和B都清空. push还是按正常做,pop注意当遇到要pop的栈为空时,因为题目保证不会对空栈进行pop操作,所以这时应直接改为对C栈进行pop操作. 这样做因为保证每个元素最多只在一次合并中被处理到,pop和push操作当然也是每个元素只做一次,所以总复杂度是O(N)的. 另一种做法是用链表来直接模拟,复杂度也是O(N),但代码量稍大一些.
ps:官方的题解的确比鄙人的好很多,鄙人也会更加努力,尽可能的寻找更优的做法。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<set>
using namespace std;
typedef long long ll;
ll a[100005];
set<ll>sp[2];
ll cnt=0;
int main(){
	int cas=1;
	while(1){
		ll n,i,j,x;
		ll aend=0;
		char c[6];
		sp[0].clear();
		sp[1].clear();
		ll now=0;
		set<ll>::iterator it;
		scanf("%lld",&n);
		cnt=0;
		if(n==0)break;
		printf("Case #%d:\n",cas++);
		while(n--){
			scanf("%s",c);
			if(c[1]=='u'){
				scanf("%s",c);
				scanf("%lld",&x);
				a[++aend]=x;
				++cnt;
				if(c[0]=='A')sp[now].insert(cnt);
				else sp[!now].insert(cnt);
			}
			else if(c[1]=='o'){
				scanf("%s",c);
				if(c[0]=='A'){
					it=sp[now].end();
					it--;
					printf("%lld\n",a[*it]);
					sp[now].erase(it);
				}
				else{
					it=sp[!now].end();
					it--;
					printf("%lld\n",a[*it]);
					sp[!now].erase(it);
				}
			}
			else{
				scanf("%s",c);
				if(c[0]=='A'){
					scanf("%s",c);
					if(sp[now].size()>sp[!now].size()){
						for(it=sp[!now].begin();it!=sp[!now].end();it++){
							sp[now].insert(*it);
						}
						sp[!now].clear();
					}
					else{
						for(it=sp[now].begin();it!=sp[now].end();it++){
							sp[!now].insert(*it);
						}
						sp[now].clear();
						now=!now;
					}
				}
				else{
					scanf("%s",c);
					if(sp[!now].size()>sp[now].size()){
						for(it=sp[now].begin();it!=sp[now].end();it++){
							sp[!now].insert(*it);
						}
						sp[now].clear();
					}
					else{
						for(it=sp[!now].begin();it!=sp[!now].end();it++){
							sp[now].insert(*it);
						}
						sp[!now].clear();
						now=!now;
					}
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值