HDU 5952 搜索

Counting Cliques

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph. 
 

Input
The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.
 

Output
For each test case, output the number of cliques with size S in the graph.
 

Sample Input
  
  
3 4 3 2 1 2 2 3 3 4 5 9 3 1 3 1 4 1 5 2 3 2 4 2 5 3 4 3 5 4 5 6 15 4 1 2 1 3 1 4 1 5 1 6 2 3 2 4 2 5 2 6 3 4 3 5 3 6 4 5 4 6 5 6
 

Sample Output
  
  
3 7 15

题意:给你n个点,m条无向边,找出有几个点集,符合大小为s,且任意两个点都有边相连。


题解:对于一个点,最多连有20条边,所以暴搜一下点集的数量,然后将这个点删去,中间加剪枝即可。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int n,m,s,mp[105][105],st[105],top,ans;
vector<int>sp[105];
bool check(int x){
    int i,j;
    for(i=2;i<=top;i++){
        if(!mp[x][st[i]])return 0;
    }
    return 1;
}
void dfs(int t,int now){
    if(top==s){
        ans++;
        return ; 
    }
    if(now==sp[t].size()){
        return ;
    }
    if(sp[t].size()-now+top<s)return ;
    if(check(sp[t][now])){
        st[++top]=sp[t][now];
        dfs(t,now+1);
        top--;
    }
    dfs(t,now+1);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&m,&s);
        memset(mp,0,sizeof(mp));
        int i,j,x,y;
        for(i=1;i<=n;i++)sp[i].clear();
        for(i=1;i<=m;i++){
            scanf("%d%d",&x,&y);
            mp[x][y]=mp[y][x]=1;
            sp[x].push_back(y);
        }
        ans=0;
        for(i=1;i<=n;i++){
            if(sp[i].size()+1<s){
                continue;
            }
            top=0;
            st[++top]=i;
            dfs(i,0);
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值