LightOJ 1125 dp

Divisible Group Sums

Given a list of N numbers you will be allowed to choose any M of them. So you can choose in NCM ways. You will have to determine how many of these chosen groups have a sum, which is divisible by D.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

The first line of each case contains two integers N (0 < N ≤ 200) and Q (0 < Q ≤ 10). Here N indicates how many numbers are there and Q is the total number of queries. Each of the next N lines contains one 32 bit signed integer. The queries will have to be answered based on these N numbers. Each of the next Q lines contains two integers D (0 < D ≤ 20) and M (0 < M ≤ 10).

Output

For each case, print the case number in a line. Then for each query, print the number of desired groups in a single line.

Sample Input

2

10 2

1

2

3

4

5

6

7

8

9

10

5 1

5 2

5 1

2

3

4

5

6

6 2

Sample Output

Case 1:

2

9

Case 2:

1


题意:n个数,每次询问选出m个数整除d的方案数量


题解:

定义dp[i][j][k]为前i个数选j个数%d为k的方案数

dp[i][j][k+a[i]]+=dp[i-1][j-1][k]  选第i个数

dp[i][j][k]+=dp[i-1][j][k]  不选第i个数

因为是32位的而且貌似有负数,所以dp要取余处理,还有就是用longlong,不然会WA,亲测。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[205],dp[205][15][25];
int main(){
	ll t,cas=1;
	scanf("%lld",&t);
	while(t--){
		ll n,q,i,j,k,d,m;
		scanf("%lld%lld",&n,&q);
		for(i=1;i<=n;i++)scanf("%lld",&a[i]);
		printf("Case %lld:\n",cas++);
		while(q--){
			scanf("%lld%lld",&d,&m);
			memset(dp,0,sizeof(dp));
			dp[1][1][(a[1]%d+d)%d]=1;
			for(i=1;i<=n;i++)dp[i][0][0]=1;
			for(i=2;i<=n;i++){
				for(j=1;j<=min(i,m);j++){
					for(k=0;k<d;k++){
						dp[i][j][((k+a[i])%d+d)%d]+=dp[i-1][j-1][k];
						dp[i][j][k]+=dp[i-1][j][k];
					}
				}
			}
			printf("%lld\n",dp[n][m][0]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值