HDU 2298 数学

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2070    Accepted Submission(s): 1149


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. 
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000. 
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit. 
 

Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
  
  
1.561582 -1 -1

题意:从原点以初速v射箭射到(x,y)处,问初速度与x轴夹角最少是多少弧度,取g=9.8N/m。有解输出四舍五入到六位小数,无解输出-1。


题解:

设夹角为a

vx=v*sin a   vy=v*cos a

t=x/vx

y=vy*t-4.8*t*t


y=x*tan a - 4.9*x*x/v/v*(tan a * tan a +1)

这个可以三分一下找到最大的y  角度a

然后二分 [0,a]  求出y即可


当x=0时  特判


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
#define eps 1e-8
#define pi acos(-1.0)
double v,x,y;
double f(double t){
    return x*tan(t)-4.9*x*x/v/v*(tan(t)*tan(t)+1);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%lf%lf%lf",&x,&y,&v);
        if(fabs(x)<eps){
            if(v*v/2/9.8<y){
                printf("-1\n");
            }
            else printf("%.6f\n",pi/2);
        }
        else{
            double lef=0,rig=pi/2;
            while(lef+eps<rig){
                double leff=lef+(rig-lef)/3;
                double rigg=lef+(rig-lef)/3*2;
                if(f(leff)<f(rigg))lef=leff;
                else rig=rigg;
            }
            if(y>f(lef))printf("-1\n");
            else{
                rig=lef;
                lef=0;
                while(lef+eps<rig){
                    double mid=(lef+rig)/2;
                    if(f(mid)>y)rig=mid;
                    else lef=mid;
                }
                printf("%.6f\n",lef);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值