九度OJ-1002

题目1002:Grading

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:10155

解决:2591

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
来源:
2011年浙江大学计算机及软件工程研究生机试真题
#include "stdio.h"
#include "stdlib.h"
#include "math.h"
//#define max(a,b) ((a)>(b)?(a):(b))
int main()
{
	int P,T,G1,G2,G3,GJ,flag,flag1,flag2;
	float Grade;
//	freopen("/mnt/hgfs/D/test/input.txt","r",stdin);
//	freopen("D:\\test/input.txt","r",stdin);
//	freopen("D:\\test/output.txt","w",stdout);
	while(scanf("%d %d %d %d %d %d",&P,&T,&G1,&G2,&G3,&GJ)!=EOF)
	{
		flag1=0;
		flag2=0;
		flag=0;
		Grade=0;
		if(abs(G1-G2)<=T)
			flag=1;
		else
		{
			if(abs(G3-G1)<=T)
				flag1=1;
			if(abs(G3-G2)<=T)
				flag2=1;
			if (flag1==1&&flag2==0)
			{
				flag=2;
			}
			if (flag1==0&&flag2==1)
			{
				flag=3;
			}
		    if(flag1==1&&flag2==1)
				flag=4;
			else if(flag1==0&&flag2==0)
				flag=5;
		}
		switch (flag)
		{
			case 1:
			Grade=(float)(G1+G2)/2;
			break;
			case 2:
			Grade=(float)(G1+G3)/2;
			break;
			case 3:
			Grade=(float)(G2+G3)/2;
			break;
			case 4:
			Grade=(float)max(max(G1,G2),G3);
			break;
			case 5:
			Grade=(float)GJ;
			break;	
		}
		printf("%.1f\n",Grade);
	}
	return 1;
}

1、学习了switch case句型
2、max,min函数到底能不能直接用,头文件是什么?
3、函数abs用于整数,函数fabs用于浮点数
4、犯了一个愚蠢的错误,有一处判断flag1是否为1时,我写成了flag1=1,应该是flag1==1,导致我没能ac,一再地Wrong Answer,改代码,没找准问题关键,改了些无关紧要的错误
5、会编程才是王道,HelloWorld
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值