Black Box--小顶堆

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10329 Accepted: 4249

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

题目链接:http://poj.org/problem?id=1442

第一次接触堆排,原来堆排这么有这么神奇的做法,直接上优先队列,完全二叉树的做法子祥大大也给我讲了一遍,虽说我还没有代码实现,但是原理是明白了,哎,还是太菜了。

这个题的题意不太好理解(对我来说英文题都不太好理解—_—|||),用示例来讲一下吧,7是代表输入7个数,4是代表有4次询问,输入询问的1代表的是刚才输入的队列中前1个数中第一小的是3,输入询问2是前两个数中第二小的是3,输入询问第一个6是前6个数中第三小的是1(-1000,-4,1),输入询问第二个6是前6个数中第4个小的是2.题意应该差不多懂了吧。

建两个优先队列,一个非递减(small),一个非递增(big),big代表的是前i-1个小的数,其实你会惊讶的发现也是一个大顶堆,对于每一个数的输入,都要判断如果大顶堆不为空且小顶堆的top小于大顶堆的top时,就把两者的top值互换。因为big总是代表前i-1个小的数,仔细想想,你会发现很神奇。


代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
int a[50000];
int main()
{
    int n,m;
    priority_queue<int ,vector<int >,less<int > > big;//非递增
    priority_queue<int ,vector<int >,greater<int > >small;//非递减
    while(~scanf("%d%d",&n,&m))
    {
        while(!small.empty())
        {
            small.pop();
        }
        while(!big.empty())
        {
            big.pop();
        }//清空
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int ans=1;
        int op;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&op);
            while(ans<=op)
            {
                small.push(a[ans]);
                if(!big.empty()&&small.top()<big.top())//判断
                {
                    int h1=small.top();
                    int h2=big.top();
                    small.pop();
                    big.pop();
                    small.push(h2);
                    big.push(h1);
                }
                ans++;
            }
            printf("%d\n",small.top());//每一次输出的数第小的数
            big.push(small.top());//因为每一次输出第i小的数,所以每一次big就要增加一
            small.pop();//小顶堆每一次出一个
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这个问题是关于Kubernetes中的 "k8s get" 命令产生的错误信息:"http blackbox-exporter-6798fb5bb4-hk7n8/blackbox-exporter": net/htt。根据错误信息,我们可以推断问题可能出现在网络模块 net/http 中。 "blackbox-exporter" 是一个监控工具,用于对 HTTP、TCP、ICMP 和 DNS 等网络服务进行探测和监控。它可以在 Kubernetes 集群中部署,以便定期检查各个服务的可用性和性能。 根据提供的错误信息,我们可以初步推断问题可能有以下几个原因: 1. blackbox-exporter 容器未成功启动或处于错误状态。需要使用 kubectl 命令检查 blackbox-exporter 容器的状态,以确定其是否正在运行,并且没有出现任何错误。 2. 网络连接问题。可能是由于网络配置不正确,导致 blackbox-exporter 无法连接到所需的服务。需要确保所在的网络环境正常,并且 blackbox-exporter 能够正确地访问目标服务。 3. blackbox-exporter 配置错误。需要检查 blackbox-exporter 的配置文件,确保它们正确地指定了要监控的服务。 为了解决这个问题,可以采取以下步骤: 1. 使用 kubectl 命令检查 blackbox-exporter 容器的状态,以确定其是否处于正常运行状态。例如,可以运行 "kubectl get pods" 命令来获取相关的信息。 2. 检查网络连接,确保网络配置正确,blackbox-exporter 能够正常连接到所需的服务。可以尝试使用其他网络工具,如 telnet 或 curl,来测试服务的连通性。 3. 检查 blackbox-exporter 的配置文件,确保配置正确并指定了正确的目标服务。可以编辑相关的配置文件并重启 blackbox-exporter 容器。 需要注意的是,我们只根据提供的错误信息做出了初步的推断,并给出了一些常见的解决方法。根据具体情况,可能需要进一步的调查和分析才能找到确切的原因和解决方案。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值