Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 5458 | Accepted: 3076 |
Description
1.The shredder takes as input a target number and a sheet of paper with a number written on it.
2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.
3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.
For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.
Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50
There are also three special rules :
1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.
For example, if the target number is 100 and the number on the sheet of paper is also 100, then
the paper is not cut.
2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.
3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.
Input
tl num1
t2 num2
...
tn numn
0 0
Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.
Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.
Output
sum part1 part2 ...
rejected
error
In the first type, partj and sum have the following meaning :
1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.
2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...
Each number should be separated by one space.
The message error is printed if it is not possible to make any combination, and rejected if there is
more than one possible combination.
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.
Sample Input
50 12346 376 144139 927438 927438 18 3312 9 3142 25 1299 111 33333 103 862150 6 1104 0 0
Sample Output
43 1 2 34 6 283 144 139 927438 927438 18 3 3 12 error 21 1 2 9 9 rejected 103 86 2 15 0 rejected题目链接:http://poj.org/problem?id=1416
这个题,我真是。。。。我靠我靠我靠,我有一个测试输出忘记注释掉了,为什么不是Output Limit Exceeded啊,为什么是wa啊,我检查的时候还看了好几次我的输出数据,没有错啊,就这样导致了我四发wa,脑袋抽风了。
我可以说这个题上来我就没看懂题意吗???!!!
网上的题意公司现在要发明一种新的碎纸机,要求新的碎纸机能够把纸条上的数字切成最接近而不超过target值。比如,target的值是50,而纸条上的数字是12346,应该把数字切成四部分,分别是1、2、34、6。因为这样所得到的和43 (= 1 + 2 + 34 + 6) 是所有可能中最接近而不超过50的。(比如1, 23, 4, 和6 就不可以,因为它们的和不如43接近50,而12, 34, 6也不可以,因为它们的和超过50了。碎纸还有以下三个要求:
1、如果target的值等于纸条上的值,则不能切。
2、如果没有办法把纸条上的数字切成小于target,则输出error。如target是1而纸条上的数字是123,则无论你如何切得到的和都比1大。
3、如果有超过一种以上的切法得到最佳值,则输出rejected。如target为15,纸条上的数字是111,则有以下两种切法11、1或者1、11.
你的任务是编写程序对数字进行划分以达到最佳值。
思路就是暴力,DFS不就是暴力吗,剪枝就是暴力里面加个if,比如111,首先将111分解成1,1,1,第二步分解成11,1,第三步分解成1,11,这样就将其所有搜索完了,在统计时只要判断输出就可以了
恩没错,我脑卡。
代码:
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dis[1000000];//标记最大可以达到的数值
int v[100000];//临时数组
int vt[100000];//输出数组
char ans[100000];
int t,maxc,len,sum;
void dfs(int x,int m,int num)//三个形参依次代表从第几个数开始递归,最大值,分解的个数
{
int flag,i;//标记最大值数组有没有变化
if(x>len-1)
{
bool flag=true;
for(int i=0;i<num;i++)
if(v[i]!=vt[i])
flag=false;//变化了
if(maxc<m)//最大值变了
{
maxc=m;
sum=num;
for(int i=0;i<num;i++)
vt[i]=v[i];
}
if(flag==false)
dis[m]++;//最大值数组个数加一
return ;
}
int y=0;
for(int i=x;i<len;i++)
{
y=y*10+(int)(ans[i]-'0');//计算下一个分解量
if(y+m<=t)
{
v[num]=y;
dfs(i+1,y+m,num+1);
}
else break;//剪枝
}
}
int main()
{
int s,i;
while(~scanf("%d %s",&t,ans))
{
memset(v,0,sizeof(v));
memset(vt,0,sizeof(vt));
memset(dis,0,sizeof(dis));
len=strlen(ans);
if(t==0&&*ans=='0')
break;
s=0;
for(i=0;i<len;i++)
s+=(int)(ans[i]-'0');//如果全部分解还大于t,则没救了。。。
if(s>t)
{
printf("error\n");
continue;
}
maxc=0,sum=0;
dfs(0,0,0);
//printf("%d\n",dis[maxc]);//就是这,四发wa!!!!!
if(dis[maxc]!=1)
printf("rejected\n");
else
{
printf("%d",maxc);
for(i=0;i<sum;i++)
{
printf(" %d",vt[i]);
}
cout<<endl;
}
}
return 0;
}