Frequent values--RMQ

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17684 Accepted: 6372

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

题目链接:http://poj.org/problem?id=3368


RMQ进阶题目,对于RMQ我的上一篇博客有所讲解。


这个题的题意是有一段序列,有Q次查询,对于每次查询,输出出现的最频繁的次数。


在RMQ的数组中存的是出现的最多的次数。


代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
int maxsum[200000][30];
int a[200000];
int b[200000];
void RMQ(int n){
    for(int i=0;i<n;i++){
        maxsum[i][0]=b[i];
    }
    for(int j=1;(1<<j)<=n;j++){
        for(int i=0;i+(1<<j)-1<n;i++){
            maxsum[i][j]=max(maxsum[i][j-1],maxsum[i+(1<<(j-1))][j-1]);
        }
    }
}
int erfen(int s,int t){//二分
    int tmp=a[t];
    int l=s;
    int r=t;
    int mid;
    while(l<r){
        mid=((l+r)>>1);
        if(a[mid]>=tmp)
            r=mid;
        else
            l=mid+1;
    }
    return r;
}
int fax(int x,int y){
    int k=(int)(log(y-x+1.0)/log(2.0));
    return max(maxsum[x][k],maxsum[y-(1<<k)+1][k]);
}
int main(){
    int n,m;
    while(~scanf("%d",&n)&&n){
        scanf("%d",&m);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        int s,t,tmp;
        for(int i=n-1;i>=0;i--){
            if(i==n-1)
                tmp=1;
            else{
                if(a[i]==a[i+1])
                    tmp++;//次数
                else
                    tmp=1;
            }
            b[i]=tmp;
        }
        RMQ(n);
        while(m--){
            scanf("%d%d",&s,&t);
            s--;//数组下标从零开始的
            t--;
            int temp=erfen(s,t);
            int ans=t-temp+1;
            t=temp-1;
            if(s>t)
                printf("%d\n",ans);
            else
                printf("%d\n",max(ans,fax(s,t)));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值