Problem E: One Stroke----暴力

Problem E: One Stroke

Time Limit: 2 Sec   Memory Limit: 1280 MB
Submit: 238   Solved: 44
[ Submit][ Status][ Web Board]

Description

    There is a complete binary tree which includes n nodes. Each node on the tree has a weight w, each edge on the tree is directed from the parent node to the child node. Give you a pen, draw from the any node along the directed edge at one stroke. It is required that the sum of those drawn nodes’ s weight is no more than k. How many node can be drawn at most in one stroke? 

Input

    The first line input an positive integer T(1<=T<=10)indicates the number of test cases. Next, each case occupies two lines. The first line input two positive integers n(1<=n<=10^6) and k,(1<=k<=10^9)

    The second line input n integers w(1<=w <=10^3),, indicate the weight of nodes from the first level of the tree and from left to right. 

Output

    For each test cases, output one line with the most number of nodes can be drawn in one stroke. If any node likes this doesn’t exists, output -1. 

Sample Input

1
5 6 
2 3 4 1 7

Sample Output

3
题目链接:http://acm.hzau.edu.cn/problem.php?cid=1029&pid=4


题目的意思就是说有一棵二叉树,问你点权之和不超过k的最长路径长度是多少。


暴力就好,从下往上

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int n,k;
int a[1000010];
int solve(int x){
    int x1=x;
    int len=0;
    while(x1>-1){
        if(a[x]-a[x1]>k){
            break;
        }
        len++;
        if(x1==0)
            break;
        x1>>=1;
    }
    return len-1;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            a[i]+=a[i/2];
        }
        int ans=0;
        for(int i=n;i>=1;i--){
            ans=max(ans,solve(i));
        }
        if(ans)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值