章三例题2——UVA 10082

WERTYU

A common typing error is to place the hands on the keyboard one row to the right of the correct position. So “Q” is typed as “W” and “J” is typed as “K” and so on. You are to decode a message typed in this manner.

Input
Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

Output
You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.

Sample Input
O S, GOMR YPFSU/

Sample Output
I AM FINE TODAY.

题意就是输出给的字符在键盘左边的一个字符。然后空格还是空格。需要注意的是\ 需要\ 才能表示为\
常量数组的运用

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
char s[]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";

int main()
{
    char c;
    while((c=getchar())!=EOF)
    {
        int len=strlen(s);
        int flag=0;
        int i;
        for(i=1;i<len&&s[i]!=c;i++);//直到找到相等的那个字符
        if(s[i]==c)
            printf("%c",s[i-1]);
        else
        printf("%c",c);//空格的时候
    }
    return 0;
}

//引用曹大神
使用常量数组建立对应关系
使用fgets()输入带空格的字符串 (不推荐gets())

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1e4;

char buf[maxn];
char arr[] = { "`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./"};

char find(int id){
    for (int i = 0; i < strlen(arr); ++i){
        if (buf[id] == arr[i]){
            return arr[i - 1];
        }
    }
}

int main(){
    while (fgets(buf, maxn, stdin)){
        int len = strlen(buf);
        for (int i = 0; i < len-1; ++i){
            if (buf[i] != ' '){
                buf[i] = find(i);
            }
            printf("%c", buf[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值