Median POJ - 3579 (两个二分求第k大的数)

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output
For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

题目意思是两个数的差的绝对值排序,找中位数。因为n的范围是1e5,然后组合有n*(n-1)/2 种,直接枚举两重循环肯定是超时的。然后二分中位数,然后看这个中位数是否可行,就要看它前面有几个比它小于或等于它的。用到了upper_bound(),这个函数返回的是一个大于目标值 的。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
const int maxn = 100005;
int a[maxn];
long long m=0;
int ok(int mid)
{
    long long cnt=0;
    for(int i=0;i<n;i++)
    {
        int p=upper_bound(a+i,a+n,a[i]+mid)-a;
        cnt+=(p-i-1);
    }
    if(cnt>=m) return 1;
    else return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        m=(long long)((n*(n-1))/2+1)/2;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int l=0,r=a[n-1]-a[0]+1,res=0;
        while(l<=r)
        {
            int mid=l+(r-l)/2;
            if(ok(mid)) {
                res=mid;
                r=mid-1;
            }
            else l=mid+1;
        }
        printf("%d\n",res);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值