HDOJ-----5499结构体排序

SDOI

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1014    Accepted Submission(s): 404


Problem Description
The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. n ( n \leq 100 ) people comes to the Select and there is m (m \leq 50) people who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is 300 .

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is x .(it is promised that not all person in one round is 0,in another way, x > 0 ). So for this round,everyone's final mark equals to his/her original mark * ( 300 / x ) .

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as 0.3 * round1's final mark + 0.7 * round2's final mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.
2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.
 

Input
There is an integer T(T \leq 100) in the first line for the number of testcases and followed T testcases.

For each testcase, there are two integers n and m in the first line (n \geq m) , standing for the number of people take part in SDOI and the allowance of the team.Followed with n lines,each line is an information of a person. Name(A string with length less than 20 ,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than 300 ) separated with a space.

 

Output
For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed m lines,every line is the name of the team with their Ultimate mark decreasing.
 
Sample Input
  
  
2 10 8 dxy male 230 225 davidwang male 218 235 evensgn male 150 175 tpkuangmo female 34 21 guncuye male 5 15 faebdc male 245 250 lavender female 220 216 qmqmqm male 250 245 davidlee male 240 160 dxymeizi female 205 190 2 1 dxy male 300 300 dxymeizi female 0 0
 
Sample Output
     
     
The member list of Shandong team is as follows: faebdc qmqmqm davidwang dxy lavender dxymeizi davidlee evensgn The member list of Shandong team is as follows: dxymeizi
这道题主要是题目太长,静下心看完就不难了。
题意就是有n人参加选拔,但是只要m人,经过两轮比赛,每个人都有自己每一轮的基础分,每一轮选取基础分最高的那个设为x,
则每个人每一轮的最后得分为: 基础分 * (300 / x)
每个人总得分为: 第一轮总分 * 0.3 + 第二轮总分 * 0.7。
ps:若没有女生,总分排名前m的被选拔上。若有女生,则在女生中总分最高的女生无论在不在前m,都要选拔上,若在前m个,则按顺序输出前m个人,若不在,则按顺序输出前m - 1个,再输出此女生。

按步骤一步一步就行了,但是m,n范围不要搞混,卡了好长时间。




#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
	double sum, ans, cnt;
	char k[1010], kk[1010];
}s[10100];
bool ppp(node m, node n){
	return m.sum > n.sum;
}
int main(){
	int a, b, c, u, p;
	double t, v, m, n;
	scanf("%d", &a);
	while(a--){
		scanf("%d%d", &b, &c);
		memset(s, 0, sizeof(s));
		u = m = n = p = 0;
		for(int i = 0; i < b; i++){
			scanf(" %s%s%lf%lf", s[i].k, s[i].kk, &s[i].ans, &s[i].cnt);
			if(s[i].kk[0] == 'f'){
				u = 1;//u来判断有没有女生
			}
			if(s[i].ans > m){
				m = s[i].ans;//m表示第一轮最高基础分
			}
			if(s[i].cnt > n){
				n = s[i].cnt;//n表示第二轮最高基础分
			}
		}
		t = 300.0 / m;
		v = 300.0 / n;
		for(int i = 0; i < b; i++){
			s[i].sum = 0.3 * t * s[i].ans + 0.7 * s[i].cnt * v;
		}
		sort(s, s + b, ppp);
		printf("The member list of Shandong team is as follows:\n");
		if(!u){
			for(int i = 0; i < c; i++){//就是这里,把选拔上的人看成了参加选拔的人,卡了很久
				printf("%s\n", s[i].k);
			}
		}
		else{
			for(int i = 0; i < c - 1; i++){
				if(s[i].kk[0] == 'f'){
					p = 1;//p判断女生在不在前m - 1个人
				}
				printf("%s\n", s[i].k);
			}
			for(int i = c - 1; i < b; i++){
				if(p || s[i].kk[0] == 'f'){//前m - 1个人中有女生,或者第i个是得分最高的女生,就输出
					printf("%s\n", s[i].k);
					break;
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值