hdu 1724 Ellipse【自适应辛普森】

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1724

Problem Description

Math is important!! Many students failed in 2+2’s mathematical test, so let’s AC this problem to mourn for our lost youth..
Look this sample picture:
这里写图片描述

A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

Input

Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

Output

For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

Sample Input
2
2 1 -2 2
2 1 0 2
Sample Output
6.283
3.142
#include <bits/stdc++.h>
using namespace std;
const double EPS=1e-4;
double a,b;
inline double F(double x)
{
    return b/a*sqrt(a*a-x*x);
}
inline double simspon(double x1,double x2)
{
    double mid=x1+(x2-x1)/2.0;
    return (F(x1)+F(x2)+4*F(mid))*(x2-x1)/6.0;
}
double cal(double x1,double x2,double eps,double A)
{
    double mid=x1+(x2-x1)/2.0;
    double L=simspon(x1,mid),R=simspon(mid,x2);
    if(fabs(L+R-A)<15*eps) return L+R+(L+R-A)/15.0;
    else return cal(x1,mid,eps/2.0,L)+cal(mid,x2,eps/2.0,R);
}
double cal(double x1,double x2,double eps)
{
    return cal(x1,x2,eps,simspon(x1,x2));
}
int main() {
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--){
        double l,r;
        cin>>a>>b>>l>>r;
        double ans=2.0*cal(l,r,EPS);
        cout<<fixed<<setprecision(3)<<ans<<endl;
    }
    return 0;
}

自适应辛普森的模板:

double F(double x)
{
    //Simpson公式用到的函数
}
double simpson(double a, double b)//三点Simpson法,这里要求F是一个全局函数
{
    double c = a + (b - a) / 2;
    return (F(a) + 4 * F(c) + F(b))*(b - a) / 6;
}
double asr(double a, double b, double eps, double A)//自适应Simpson公式(递归过程)。已知整个区间[a,b]上的三点Simpson值A
{
    double c = a + (b - a) / 2;
    double L = simpson(a, c), R = simpson(c, b);
    if (fabs(L + R - A) <= 15 * eps)return L + R + (L + R - A) / 15.0;
    return asr(a, c, eps / 2, L) + asr(c, b, eps / 2, R);
}
double asr(double a, double b, double eps)//自适应Simpson公式(主过程)
{
    return asr(a, b, eps, simpson(a, b));
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值