hdoj 1787 GCD Again (欧拉函数模板 )

B - B(HDOJ 1787 GCD AGINE)
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest? 
No? Oh, you must do this when you want to become a "Big Cattle". 
Now you will find that this problem is so familiar: 
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: 
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1. 
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study. 
Good Luck! 
 

Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed. 
 

Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 
 

Sample Input

     
     
2 4 0
 

Sample Output

     
     
0 1
 

while(n%i==0)
n=n/i;这一步还是不怎么理解,怎么筛选的,先记住吧!

代码:

欧拉函数:小于n的所有质数的个数。
通式:euler(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn),
其中p1,p2……pn为x的所有素因数,x是不为0的整数。

#include<cstdio>
int euler(int n)
{
    int eu=n;//欧拉函数
    int i;
    for(i=2;i*i<=n;i++)//i*i提高运算效率
    {
        if(n%i==0)        
            eu=eu/i*(i-1);//防止中间数据溢出,所以先除后乘        
        while(n%i==0)        
            n=n/i;//筛选i的倍数,避免再次累加,        
    }
    if(n>1)//本身就是质数    
        eu=eu/n*(n-1);//注意这里是n不是i    
    return eu;
}
int main()
{
    int n;
    while(~scanf("%d",&n)
    {
        printf("%d\n",n-euler(n)-1);//题目要求>1
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值