hdoj 5671 Matrix (模拟+技巧)

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1392    Accepted Submission(s): 554


Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000) .Then we perform q(1q100,000) operations:

1 x y: Swap row x and row y (1x,yn) ;

2 x y: Swap column x and column y (1x,ym) ;

3 x y: Add y to all elements in row x (1xn,1y10,000) ;

4 x y: Add y to all elements in column x (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:

The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1Mi,j10,000) for all (1in,1jm) .
The following q lines contains three integers a(1a4) , x and y .
 

Output
For each test case, output the matrix M after all q operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 
按着题意去模拟,RE了,看了大神博客,技巧用的挺好的,
数组模拟矩阵每个位置变化和数值变化 ,最后按变化后的行列坐标和变化的值输出

注意行列变换的时候,也要进行变化值的交换

代码:

/*
技巧,数组模拟矩阵每个位置变化和数值变化 
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1010][1010];
 int main()
 {
 	int t,n,m,q;
 	int s,x,y;
 	int row[1010],col[1010];
 	int sumr[1010],sumc[1010];
 	scanf("%d",&t);
 	while(t--)
 	{	
	 	scanf("%d%d%d",&n,&m,&q);
 		int i,j;
 		for(i=1;i<=n;i++)
 		{
 			for(j=1;j<=m;j++)
 			{
 				scanf("%d",&a[i][j]);
			 }
		 }
		 memset(sumr,0,sizeof(sumr));
		 memset(sumc,0,sizeof(sumc));
		 for(i=1;i<=n;i++)	row[i]=i;
		 for(j=1;j<=m;j++)	col[j]=j;
		 for(i=0;i<q;i++)
		 {
		 	scanf("%d%d%d",&s,&x,&y);
		 	if(s==1)    
			 {
				swap(row[x],row[y]);
				swap(sumr[x],sumr[y]);
			 }
		 	if(s==2)
			 {
				 swap(col[x],col[y]);
				 swap(sumc[x],sumc[y]);	
			}	
		 	if(s==3)
			 	sumr[x]+=y;
		 	if(s==4) sumc[x]+=y;
		 }
		 for(i=1;i<=n;i++)
		 {
		 	for(j=1;j<m;j++)
		 		printf("%d ",a[row[i]][col[j]]+sumr[i]+sumc[j]);
		 	printf("%d\n",a[row[i]][col[m]]+sumr[i]+sumc[m]);
		 }
	 }
 	return 0;
 }
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值