poj 2104 K-th Number (分桶法和平方分割)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 53887 Accepted: 18530
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3
题意:给出一个数列,询问其中一段区间 [L,R]中第k大的数

题解: m的数很大所以直接每次都快排的方法不可取,看到网上有很多人用的是主席树和线段树……然而都不会……

资料书上正好用这道题进行讲解的 分桶法和平方分割 的数据结构 ,看了好长时间,大概给懂了

分桶法:是把一排物品或者平面分成桶,每个桶分别维护自己内部的信息,以达到高效的计算的目的的方法。

其中,平方分割是把排成一排的n个元素每 根号下n个分在一个桶里进行维护的方法的统称。将复杂度降到sqrt(n)。

如果x是第k个数,那么一定有:在区间中不超过x的数有不少于k个;  在区间中小于x的数有不到k个

通过分桶法,每个桶中保留B个有序的数据,被区间完全包含的桶直接二分搜索小于等于k的数的个数,不被完全包含的桶就逐个遍历


code

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;

#define MAXN 100010
#define MAXM 5010
#define B 1000   //桶的大小

//输入
int n,m;
int a[MAXN];
int L[MAXM],R[MAXM],K[MAXM];

int num[MAXN];  //对A排序后的结果
vector<int> bucket[MAXN/B];  //每个桶排序后的结果

void solve()
{
    for(int i=0;i<n;i++)
    {
        bucket[i/B].push_back(a[i]);
        num[i]=a[i];
    }
    sort(num,num+n);
    for(int i=0;i<n/B;i++)
        sort(bucket[i].begin(),bucket[i].end());
    for(int i=0;i<m;i++)
    {
        //求[L,R]区间的第K个数
        int l=L[i]-1,r=R[i],k=K[i];
        int left=-1,right=n-1,mid;
        while(right-left>1)
        {
            mid=(left+right)/2;
            int x=num[mid];
            int tl=l,tr=r,c=0;

            //区间两端多出的部分
            while(tl<tr&&tl%B!=0){
                if(a[tl++]<=x) c++;
            }
            while(tl<tr&&tr%B!=0){
                if(a[--tr]<=x) c++;
            }

            //对每个桶进行计算
            while(tl<tr)
            {
                int  b=tl/B;
                c+=upper_bound(bucket[b].begin(),bucket[b].end(),x)-bucket[b].begin();
                tl+=B;
            }

            if(c>=k)
                right=mid;
            else
                left=mid;
        }
        printf("%d\n",num[right]);
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
    for(int i=0;i<m;i++)
        scanf("%d%d%d",&L[i],&R[i],&K[i]);
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值