poj 2719 Faulty Odometer (数学思维)

Faulty Odometer

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9277 Accepted: 5744

Description

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440

code

/***
题意:里程表坏了,如果下一秒跳转的数轮到诸如4、40、400……
会直接跳到5,问在0到给出的数中 会看到的数有多少个
思路:可以一位一位的计算,先从高位开始,算出当前位的可取值个数,然后比它低的位
每位可取的值的个数一定是9
***/

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
    char str[20];
    int m,ans,len;
    while(~scanf("%s",str))
    {
        if(strcmp(str,"0")==0)
            break;
        len=strlen(str);
        m=0;ans=0;
        for(int i=0;i<len;i++)
            m=m*10+str[i]-'0';
        for(int i=0;i<len;i++)
        {
            int num=str[i]-'0';
            if(num>4) num--;//当前位会跳过4
            ans+=num*pow(9,len-i-1);
        }
        printf("%d: %d\n",m,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值