pku online 1001

 

Exponentiation
Time Limit: 500MS
 
Memory Limit: 10000K
Total Submissions: 31063
 
Accepted: 7032
Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
Hint
If you don't know how to determine wheather encounted the end of input:
s is a string and n is an integer
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want

/*while(scanf(%s%d",s,&n)!=EOF) //this also work    */

{

...

}
Source
 
代码:

#include<iostream>
#include<string>
using namespace std;

string clear(string s)
{
 if(s=="")
 s="0";
 
 while(s.length()>0 && s[0]=='0')
  s.erase(0,1);
 
 if(s=="")
  s="0";

 return s;
}

string subclear(string s)
{
 if(s=="")
 s="0";

 while(s.length()>0 && s[s.length()-1]=='0')
  s.erase(s.length()-1,1);
 
 if(s=="")
 s="0";
 return s;
}


string addition(string s1,string s2)
{
 int i;
 while(s1.length()<s2.length())
  s1="0"+s1;
 while(s1.length()>s2.length())
  s2="0"+s2;
 s1="0"+s1;
 s2="0"+s2;
   for(i=s1.length()-1;i>=0;i--)
 {
  s1[i]+=s2[i]-'0';
  if(s1[i]>'9')
  {
   s1[i]-=10;
   s1[i-1]+=1;
  }
 }
 return clear(s1);
}

string multiply(string s1,string s2)
{
int i;
char C;
string Result;
int str1=0,str2=0;
string s11,s12;

 if(s1=="0" || s2=="0") return "0";
 for(i=0;i<s1.length();i++)
 {
  if(s1[i]=='.') {
   str1=s1.length()-1-i;
   s1.erase(i,1);
   break;
   }
  if(i==s1.length()-1 && s1[s1.length()-1]!='.')
  str1=0;
 }
 for(i=0;i<s2.length();i++)
 {
  if(s2[i]=='.') {
   str2=s2.length()-1-i;
   s2.erase(i,1);
   break;
   }
  if(i==s2.length()-1 && s2[s2.length()-1]!='.')
  str2=0;
 }
    Result="0";
    for(i=s2.length()-1;i>=0;i--)
 {  
         for(C='1';C<=s2[i];C++)
         Result=addition(Result,s1);

         s1+="0";
 }
 if(str1+str2==0) return clear(Result);
 else if(str1+str2<Result.length())
  Result.insert(Result.length()-str1-str2,".");
 else if(str1+str2==Result.length())
 {
  Result="0."+Result;
 }
 else
 {
  while(str1+str2>Result.length())
   Result="0"+Result;
  Result="0."+Result;
 }
 for(i=0;i<Result.length();i++)
 {
  if(Result[i]=='.') {
   s11=Result.substr(0,i);
   s12=Result.substr(i+1);
   break;
   }
 }
 s11=clear(s11);
 s12=subclear(s12);
 
 if(s12=="0") return s11;
 else if(s11=="0") return "."+s12;
 else return s11+"."+s12;
}

string mul(string s,int n)
{
 int i=0;
 if(n==0) return "1";
 if(n==1) return multiply(s,"1");
 else if(n==2) return multiply(s,s);
 else return n%2==0?multiply(mul(s,n/2),mul(s,n/2)):multiply(mul(s,(n+1)/2),mul(s,(n-1)/2));
}

int main()
{
 string str;
 int s;
  

 while(cin>>str>>s)
 {
  str=mul(str,s);
  cout<<str<<endl;
 }

return 0;
}

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值