ADS1.2升级到RealView2.2

 两个基本上没什么变化,编译环境由CodeWarrior for ADS变成了CodeWarrior for RVDS,调试环境由AXD debugger 变成了AXD debugger1.3.1,甚至原来的H-JTAG仿真软件的配置问题都可通用,太爽了!

目前编译时发现一点问题,原来用ADS编译通过的文件,现在出现了错误,提示:

Error: L6238E: foo.o(.text) contains invalid call from '~PRES8' function to 'REQ8' function foobar

找了一下,原来RVDS2.0~3.1版本都有这个问题,要求保持堆栈8字节对齐,如果没有设置这个属性,会出现错误。

两种办法解决此问题:

1:在代码编译前面设置属性,可以解决这个问题(我已经试过了)。例如将:

AREA Init, CODE, READONLY

变成:

PRESERVE8
AREA Init, CODE, READONLY

2:在linker的命令行加入下面参数:

--diag_suppress 6238

这样编译器就不再检查堆栈对齐问题了。

这种方法还可以消除L6306W 的警告,--diag_suppress 6306即可。

参考网址:

http://www.arm.com/support/faqdev/1242.html

http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.dui0204hc/Cacehagj.html

http://www.keil.com/support/docs/3268.htm

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页