uva 1354——Mobile Computing

There is a mysterious planet called Yaen, whose space is 2-dimensional. There are many beautiful stones on the planet, and the Yaen people love to collect them. They bring the stones back home and make nice mobile arts of them to decorate their 2-dimensional living rooms.

In their 2-dimensional world, a mobile is defined recursively as follows:

  • a stone hung by a string, or
  • a rod of length 1 with two sub-mobiles at both ends; the rod is hung by a string at the center of gravity of sub-mobiles. When the weights of the sub-mobiles are n and m , and their distances from the center of gravity are a and b respectively, the equation n x a = m x b holds.

\epsfbox{p3403a.eps}

For example, if you got three stones with weights 1, 1, and 2, here are some possible mobiles and their widths:

\epsfbox{p3403b.eps}

Given the weights of stones and the width of the room, your task is to design the widest possible mobile satisfying both of the following conditions.

  • It uses all the stones.
  • Its width is less than the width of the room.

You should ignore the widths of stones. In some cases two sub-mobiles hung from both ends of a rod might overlap (see the figure on the right). Such mobiles are acceptable. The width of the example is (1/3) + 1 + (1/4) .

\epsfbox{p3403c.eps}

Input 

The first line of the input gives the number of datasets. Then the specified number of datasets follow. A dataset has the following format.


r

s

w1

$ \vdots$

ws


r is a decimal fraction representing the width of the room, which satisfies 0 < r < 10 . s is the number of the stones. You may assume 1$ \le$s$ \le$6 . wi is the weight of the i -th stone, which is an integer. You may assume 1$ \le$wi$ \le$1000 .

You can assume that no mobiles whose widths are between r - 0.00001 and r + 0.00001 can be made of given stones.

Output 

For each dataset in the input, one line containing a decimal fraction should be output. The decimal fraction should give the width of the widest possible mobile as defined above. An output line should not contain extra characters such as spaces.

In case there is no mobile which satisfies the requirement, answer `-1' instead.

The answer should not have an error greater than 0.00000001. You may output any numb er of digits after the decimal point, provided that the ab ove accuracy condition is satisfied.

Sample Input 

5 
1.3 
3 
1 
2 
1 
1.4 
3 
1 
2 
1 
2.0 
3 
1 
2 
1 
1.59 
4 
2 
1 
1 
3 
1.7143 
4 
1 
2 
3 
5

Sample Output 

-1 
1.3333333333333335 
1.6666666666666667 
1.5833333333333335 

1.7142857142857142

题意:给出房间的宽度r和s个吊坠的重量wi,设计一个尽量宽(不超过r)的天平来挂所有吊坠。

思路:回溯法去枚举所有的状态找出max即可。枚举时采用了状态压缩保存了左右集合,然后根据左右集合的情况来推出根节点的情况。一个重要的剪枝就是用vis标记,枚举过的集合将不再枚举。

code:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <sstream>
#include <string>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <bitset>

using namespace std;

typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;

const int INF=0x3fffffff;
const int inf=-INF;
const int N=1000000;
const int M=2005;
const int mod=1000000007;
const double pi=acos(-1.0);

#define cls(x,c) memset(x,c,sizeof(x))
#define fr(i,s,n) for (int i=s;i<=n;i++)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define lrt  rt<<1
#define rrt  rt<<1|1
#define middle int m=(r+l)>>1
#define lowbit(x) (x&-x)
#define pii pair<int,int>
#define mk make_pair
#define IN freopen("in.txt","r",stdin);
#define OUT freopen("out.txt","w",stdout);

struct node
{
    double lt,rt;
    node(double ll=0, double rr=0) {lt= ll; rt= rr;}
};
double pr,w[8],sums[1<<8];
int T,n,vis[1<<8];
vector<node>v[1<<8];

void dfs(int s)
{
    if (vis[s]) return;
    vis[s]=1;

    for (int p=(s-1)&s;p;p=(p-1)&s)
    {
        int r=s^p;

        double dl=sums[r]/sums[s];
        double dr=sums[p]/sums[s];
        dfs(r); dfs(p);

        for (int i=0;i<v[p].size();i++)
            for (int j=0;j<v[r].size();j++)
            {
                node t;
                t.lt=max(v[p][i].lt+dl,v[r][j].lt-dr);
                t.rt=max(v[r][j].rt+dr,v[p][i].rt-dl);
                if (t.lt+t.rt<pr) v[s].push_back(t);
            }
    }
}
int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%lf %d",&pr,&n);
        fr(i,0,n-1) scanf("%lf",&w[i]);

        cls(vis,0);
        int s=(1<<n)-1;
        fr (i,0,s)
        {
            v[i].clear();
            sums[i]=0;
            fr (j,0,n-1)
            if (i&(1<<j)) sums[i]+=w[j];
        }

        fr (i,0,n-1) v[1<<i].push_back(node());

        dfs(s);
        double ans=-1;
        for (int i=0;i<v[s].size();i++)
            ans=max(ans,v[s][i].lt+v[s][i].rt);
        printf("%.10lf\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值