寒假训练营第五天(贪心)C题:FatMouse' Trade

C - FatMouse’ Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input


The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.


Output


For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input


5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output


13.333
31.500

题解:对于英语及菜的我肯定在开始是不会看这道题的,其实看懂题意后就是一道简单的贪心算法题,在这道题我又踩了坑,在这既是提醒自己,也是说说自己的心得:一定不要特立独行,判题机可是六亲不认的!!!,首先认为只要能够运行不超时即可,但是提交WA。。。

首先是WA的代码

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct room
{
    double  a;
    double  b;
}rm[1005];
bool cmp(room m,room n)
{
    return (double)(m.a/m.b)>(n.a/n.b);
}
int main()
{
    int N,M,i;
    while(~scanf("%d%d",&M,&N))
    {
        if(N==-1&&M==-1)
            break;
        for(i=0;i<N;i++)
        {
            scanf("%lf%lf",&rm[i].a,&rm[i].b);
        }
        sort(rm,rm+N,cmp);
        double sum=0;
        double amount=0;
        int j=0;
        while(sum<=M)                                            //判断有点不知所云,导致遍历出了问题
        {
            if((sum+rm[j].b)<=M)
            {
                sum+=rm[j].b;
                amount+=rm[j].a;
            }
            else
            {
                double rest=M-sum;
                amount+=(rest/rm[j].b)*rm[j].a;
                sum+=rm[j].b;
            }
            j++;
        }
        printf("%.3f\n",amount);
    }
    return 0;
}

最后是AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct room
{
    double  a;
    double  b;
}rm[1005];
bool cmp(room m,room n)
{
    return (m.a/m.b)>(n.a/n.b);
}
int main()
{
    int N,M,i;
    while(~scanf("%d%d",&M,&N))
    {
        if(N==-1&&M==-1)
            break;
        for(i=0;i<N;i++)
        {
            scanf("%lf%lf",&rm[i].a,&rm[i].b);
        }
        sort(rm,rm+N,cmp);
        double sum=0;
        double amount=0;
        for(int j=0;j<N;j++)                                                 //遍历简洁明了
        {
            if((sum+rm[j].b)<=M)
            {
                sum+=rm[j].b;
                amount+=rm[j].a;
            }
            else
            {
                double rest=M-sum;
                amount+=(rest/rm[j].b)*rm[j].a;
                break;
            }
        }
        printf("%.3f\n",amount);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值