hdu 2119:Matrix(匈牙利算法)

hdu 2119:Matrix(匈牙利算法)


Problem Description


Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the ‘1’ in this row or this column .

Your task is to give out the minimum times of deleting all the ‘1’ in the matrix.


Input


There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.


Output


For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the ‘1’ in the matrix.


Sample Input


3 3
0 0 0
1 0 1
0 1 0
0


Sample Output


2

当然,开始并没有做出来,以为暴力或者找找规律就能A,居然是一道匈牙利算法的水题,
关于匈牙利算法:此处有传送门

于是上代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int mp[110][110];
int vis[110];
int a[110];
int n,m;
int Find(int i)
{
    for(int j=1;j<=m;j++)
    {
        if(mp[i][j]==1&&vis[j]==0)
        {
            vis[j]=1;
            if(a[j]==0||Find(a[j]))
            {
                a[j]=i;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        scanf("%d",&m);
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        memset(mp,0,sizeof(mp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
                scanf("%d",&mp[i][j]);
        }
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(Find(i))
            {
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值