[刷题]算法竞赛入门经典/第六章/铁轨(例题6-2)

Rails (UVA原题的链接单击这里哦?????)


Sample Input:?
-------------------------------------------------
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
-------------------------------------------------
Sample Output:?
-------------------------------------------------
Yes
No

Yes
-------------------------------------------------
#include <bits/stdc++.h>

using namespace std;

const int MAXN = 1024;
int coachs[MAXN];

int main() {
    int n;
    //这个应该代表输入n,并且n不为零,则运行while循环里面的,如果为零,则跳出循环
    while (cin >> n, n) {
        stack<int> s;
        while (cin>>coachs[0],coachs[0]) {
            for (int i = 1; i < n; ++i) {
                cin >> coachs[i];
            }
            int aId = 1, bIndex = 0;//aId是进站车厢序号,bIndex是出站数组索引
            bool ok = true;
            while (bIndex < n) {
                if (aId == coachs[bIndex]) {
                    aId++;
                    bIndex++;
                } else if (!s.empty() && coachs[bIndex] == s.top()) {
                    s.pop();
                    bIndex++;
                } else if (aId <= n) {
                    s.push(aId++);
                } else {
                    ok = false;
                    break;
                }
            }
            cout << (ok ? "Yes" : "No") << endl;//因为把Yes写成yes,所以一直不通过!
        }
        cout << endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值