A + B Again (16进制的直接运算)

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16107    Accepted Submission(s): 6961


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
  
  
0 2C 11 -2C -90
 




在十六进制中,除了用0~9外,还用A、B、C、D、E、F分别表示10~15,而十六进制和十进制的不同之处就是在计算时是逢16进一的。如1A(16进制)转化为十进制为1×16+10=26,而214(16进制)转化为十进制为2×16^2+1×16+4=532。(16^2表示16的平方,16^3表示16的3次方,依此类推),而1111(16进制)转化为十进制为1×16^3+1×16^2+1×16+1=4369。
    计算的时候也是从低位算起,满16进一,如:
    16进制下计算1A+29:最低位A+9即为19,超过16,所以A+9=10+9(十进制)=19(十进制)=13(16进制),高位的1加到前面去,则答案为1A+29=43(16进制)。


HINT:16进制也可以直接加减



#include<stdio.h>
int main()
{
    __int64 a,b;
    while(scanf("%I64X%I64X",&a,&b)!=EOF)
    {
        b=a+b;
        if(b<0)
        {
            b=-b;
            printf("-");
        }
        printf("%I64X\n",b);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值