Anniversary party(树形DP入门)

 

                                                                                                                   Anniversary party
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4826Accepted: 2733

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

树形DP入门,参加part,

思路:

任何一个点的取舍可以看作一种决策,那么状态就是在某个点取的时候或者不取的时候,以他为的子树能有的最大活跃总值。分别可以用f[i,1]f[i,0]表示第i个人来和不来。

当i来的时候,dp[i][1] += dp[j][0];//j为i的下属

当i不来的时候,dp[i][0] +=max(dp[j][1],dp[j][0]);//j为i的下属

 

 

#include<iostream> 
#include<cmath> 
#include<algorithm> 
#include<vector> 
#include<cstdio> 
#include<cstdlib> 
#include<cstring> 
#include<string> 
using namespace std;  
#define maxn 6005 
 
int n; 
int dp[maxn][2],father[maxn];//dp[i][0]0表示不去,dp[i][1]1表示去了 
bool visited[maxn]; 
 
void tree_dp(int node) 

    int i; 
    visited[node] = 1; 
    for(i=1; i<=n; i++) 
    { 
        if(!visited[i]&&father[i] == node)//i为下属 
        { 
            tree_dp(i);//递归调用孩子结点,从叶子结点开始dp 
            //关键 
            dp[node][1] += dp[i][0];//上司来,下属不来 
            dp[node][0] +=max(dp[i][1],dp[i][0]);//上司不来,下属来、不来 
        } 
    } 

 
int main() 

    int i; 
    int f,c,root; 
    while(scanf("%d",&n)!=EOF) 
    { 
        memset(dp,0,sizeof(dp)); 
        memset(father,0,sizeof(father)); 
        memset(visited,0,sizeof(visited)); 
        for(i=1; i<=n; i++) 
        { 
            scanf("%d",&dp[i][1]); 
        } 
        root = 0;//记录父结点 
        bool beg = 1; 
        while (scanf("%d %d",&c,&f),c||f) 
        { 
            father[c] = f; 
            if( root == c || beg ) 
            { 
                root = f; 
            } 
        } 
        while(father[root])//查找父结点 
            root=father[root]; 
        tree_dp(root); 
        int imax=max(dp[root][0],dp[root][1]); 
        printf("%d\n",imax); 
    } 
    return 0; 
 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值