Box Relations

Box Relations

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 348    Accepted Submission(s): 145


 

Problem Description
There are n boxes C1, C2, ..., Cn in 3D space. The edges of the boxes are parallel to the x, y or z-axis. We provide some relations of the boxes, and your task is to construct a set of boxes satisfying all these relations.

There are four kinds of relations (1 <= i,j <= n, i is different from j):
  • I i j: The intersection volume of Ci and Cj is positive.
  • X i j: The intersection volume is zero, and any point inside Ci has smaller x-coordinate than any point inside Cj.
  • Y i j: The intersection volume is zero, and any point inside Ci has smaller y-coordinate than any point inside Cj.
  • Z i j: The intersection volume is zero, and any point inside Ci has smaller z-coordinate than any point inside Cj.
.
Input
There will be at most 30 test cases. Each case begins with a line containing two integers n (1 <= n <= 1,000) and R (0 <= R <= 100,000), the number of boxes and the number of relations. Each of the following R lines describes a relation, written in the format above. The last test case is followed by n= R=0, which should not be processed.
Output

            For each test case, print the case number and either the word POSSIBLE or IMPOSSIBLE. If it\\\\\\\'s possible to construct the set of boxes, the i-th line of the following n lines contains six integers x1, y1, z1, x2, y2, z2, that means the i-th box is the set of points ( x,y,z) satisfying x1 <= x <= x2, y1 <= y <= y2, z1 <= z <= z2. The absolute values of x1, y1, z1, x2, y2, z2 should not exceed 1,000,000.

Print a blank line after the output of each test case.
Sample Input
3 2
I 1 2
X 2 3
3 3
Z 1 2
Z 2 3
Z 3 1
1 0
0 0
Sample Output
Case 1: POSSIBLE
0 0 0 2 2 2
1 1 1 3 3 3
8 8 8 9 9 9

Case 2: IMPOSSIBLE

Case 3: POSSIBLE
0 0 0 1 1 1
 
对每个坐标轴单独处理。在x轴上放置2 * n个顶点,对应长方体的上下底面,加入偏序关系,对着2 * n个顶点拓扑排序。
 
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int MAXR = 1e5 + 10;
//next是下一条边的编号, index是边的编号 
int u[4][MAXR], v[4][MAXR], next[4][MAXR], first[4][MAXR], index[4], res[4][MAXR], indegree[4][MAXR];   
int n, r;
void insert(int k, int a, int b){  // k 是x, y, z轴,u -> v表示u > v 
	u[k][index[k]] = a;  //
	v[k][index[k]] = b;
  	next[k][index[k]] = first[k][a];
	first[k][a] = index[k];
	indegree[k][b]++; 
	index[k]++;  //自加表示k轴上的下一条 编号
}
void init(){
	for(int k = 1; k <=3; k++){
		for(int i = 1; i <= n; i++){
			insert(k, i, i+n);
		}
	}
}
bool topo(int k){  //拓扑排序 
	int cnt = 1;
	queue<int> q;
	for(int i = 1; i <= 2 * n; i++){
		if(indegree[k][i] == 0){
			q.push(i);
			indegree[k][i]--;
			res[k][cnt++] = i;
		}
	}
	while(!q.empty()){
		int u = q.front();
		q.pop();
		for(int e = first[k][u]; e != -1; e = next[k][e]){
			indegree[k][v[k][e]]--;
			if(indegree[k][v[k][e]] == 0) {
				q.push(v[k][e]);
				res[k][cnt++] = v[k][e];
			}
		}	
	}
	if(cnt > 2 * n) return true;
	else return false;
}
void output(){
	int ans[4][MAXR];
	memset(ans, 0, sizeof(ans));
	for(int k = 1; k <= 3; k++){
		for(int i = 1; i <= 2 * n; i++){
			ans[k][res[k][i]] = i; 
		}
	}	
	for(int i = 1; i <= n; i++){	
		printf("%d %d %d ", ans[1][i], ans[2][i], ans[3][i]);
		printf("%d %d %d\n", ans[1][i + n], ans[2][i + n], ans[3][i + n]);
	}

}
int main(){
	char f;
	int a, b, kase = 1;
	while(scanf("%d%d", &n, &r) && (n != 0 || r != 0)){
		memset(first, -1, sizeof(first));
		memset(index, 0, sizeof(index));
		memset(next, -1, sizeof(next));
		memset(indegree, 0, sizeof(indegree));
		memset(u, 0, sizeof(u));
		memset(v, 0, sizeof(v));
		memset(res, 0, sizeof(res));
		init();
		getchar();
		for(int i = 0; i < r; i++){
			scanf("%c %d %d", &f, &a, &b);
			getchar();
			if(f == 'I'){
				for(int k = 1; k <= 3; k++){
					insert(k, b, a+n);
					insert(k, a, b+n);	
				}
			}
			else {
				insert(f - 'X' + 1, a+n, b);
			}
		}
		printf("Case %d: ", kase++);
		bool flag = true;
		for(int k = 1; k <= 3; k++){
			if(!topo(k)) flag = false;
		}
		if(flag){
			printf("POSSIBLE\n");
			output();
		}
		else printf("IMPOSSIBLE\n");
		printf("\n");
	}
	return 1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值