HDU - 1542 Atlantis

Problem Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

 

Sample Input

2 10 10 20 20 15 15 25 25.5 0

Sample Output

Test case #1

Total explored area: 180.00

思路:
将所有的区域的竖线延长后,它们分隔出的横轴区间可用线段树的叶子节点表示。

对于每个长方形区域的横线按照y轴高度排序,从下向上扫描每一条横线。对于一个区域的下面那条横线标记flag为1,上面那条横线标记flag为-1。

1:当线段树的一个叶子节点的flag原本为0,如果新扫描到的横线的flag为1,这时更新这个线段的底的y坐标。

2:当线段树的一个叶子节点的flag原本为1,如果新扫描到的横线的flag为-1,则计算新区域。

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

typedef long long ll;
const int MAXN = 205;

double area = 0;
double x[MAXN];

struct Line
{
	double l, r;
	double y;
	int flag;
}line[MAXN];

struct Node
{
	double l, r;
	double y;
	int flag;
	bool end;
}node[MAXN << 2];

bool cmp(const Line &a, const Line &b)
{
	return a.y < b.y;
}

void build(int rt, int l, int r)
{
	node[rt].l = x[l];
	node[rt].r = x[r];
	node[rt].y = 0;
	node[rt].flag = 0;

	if (l + 1 == r)
	{
		node[rt].end = true;
		return;
	}

	node[rt].end = false;
	int mid = l + (r - l) / 2;
	build(rt << 1, l, mid);
	build(rt << 1 | 1, mid, r);
}

void update(int rt, double l, double r, int flag, double y)
{
	if (l >= node[rt].r || r <= node[rt].l)
	{
		return;
	}

	if (node[rt].end)
	{
		if ((node[rt].flag == 1) && (flag == -1))
		{
			area += (node[rt].r - node[rt].l) * (y - node[rt].y);
		}
		else if ((node[rt].flag == 0) && (flag == 1))
		{
			node[rt].y = y;
		}

		node[rt].flag += flag;
	}
	else
	{
		update(rt << 1, l, r, flag, y);
		update(rt << 1 | 1, l, r, flag, y);
	}
}

int main() 
{
	int n;
	double x1, y1, x2, y2;
	int Case = 0;

	while (~scanf("%d", &n) && n)
	{
		Case++;
		area = 0;
		int count = -1;
		for (int i = 0; i < n; i++)
		{
			scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
			count++;
			x[count] = x1;
			line[count].l = x1;
			line[count].r = x2;
			line[count].y = y1;
			line[count].flag = 1;

			count++;
			x[count] = x2;
			line[count].l = x1;
			line[count].r = x2;
			line[count].y = y2;
			line[count].flag = -1;
		}
		sort(x, x + count + 1);
		sort(line, line + count + 1, cmp);

		build(1, 0, count);

		for (int i = 0; i <= count; i++)
		{
			update(1, line[i].l, line[i].r, line[i].flag, line[i].y);
		}

		printf("Test case #%d\n", Case);
		printf("Total explored area: %.2lf\n\n", area);
	}

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值