hdu 3001 Travelling

Problem Description

After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input

There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.

Output

Output the minimum fee that he should pay,or -1 if he can't find such a route.

Sample Input

2 1

1 2 100

3 2

1 2 40

2 3 50

3 3

1 2 3

1 3 4

2 3 10

 

Sample Output

100

90

7

思路:

状态压缩dp。用三进制来表示每个城市的三个状态。

dp[i][j]表示状态为i,终点为j时的最小开销。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <stdio.h>
using namespace std;

typedef long long ll;
const int MAXS = 60000;
const int MAXN = 12;
const int INF = 0x3f3f3f3f;
int dp[MAXS][MAXN];
int dis[MAXN][MAXN];

int main() 
{
    int m, n;
    while (scanf("%d%d", &n, &m) != EOF) 
	{
        memset(dis, 0x3f, sizeof(dis));
        memset(dp, 0x3f, sizeof(dp));

        for (int i = 0; i < m; i++) 
		{
            int x, y, c;
			scanf("%d%d%d", &x, &y, &c);
			x--;
			y--;
            dis[y][x] = dis[x][y] = min(c, dis[x][y]);
        }

        int total = 1;
        
		for (int i = 0; i < n; i++) 
		{
            dis[i][i] = 0;
            total *= 3;
        }

        for (int i = 0; i < total; i++) 
		{
            for (int j = 0; j < n; j++) 
			{
                int s = i, add = 1;
                int t = j;
                while (t--) 
				{
                    s /= 3;
                    add *= 3;
                }
                s %= 3;
                if (s < 2) 
				{
                    dp[add][j] = 0; 
                    s = i;
                    for (int k = 0; k < n; k++) 
					{
                        if (s % 3 > 0) 
						{
                            dp[i + add][j] = min(dp[i + add][j], dp[i][k] + dis[k][j]);
                        }
                        s /= 3;
                    }
                }
            }
        }

        int result = INF;
        for (int j = 0; j < n; j++) 
		{
            result = min(result, dp[total - 1][j]);
        }
        if (result == INF)
		{
			result = -1;
		}
        
		cout << result << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值