poj 3211 Washing Clothes 01背包

Washing Clothes
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 8157 Accepted: 2530

Description

Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?

Input

The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.

Output

For each test case output on a separate line the time the couple needs for washing.

Sample Input

3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0

Sample Output

10
 
 
 
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;

struct node{
    int t;
    char col[11];
}a[111];

int cmp(node A,node B){
    return strcmp(A.col,B.col)>0;
}

int f[111111];

int main()
{
    int m,n;
    char s[11][11];
    while(cin>>m>>n&&m&&n){
        int i,j,k,t,sum,ans=0,vis,res;
        for(i=0;i<m;i++)
            scanf("%s",s[i]);
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
            scanf("%d%s",&a[i].t,a[i].col);
        sort(a,a+n,cmp);
        t=0;
        sum=0;
        for(i=0;i<=n;i++){
            if(strcmp(a[t].col,a[i].col)||(t==n-1)){
                if(t==n-1){
                    i=n;
                    if(strcmp(a[n-1].col,a[n-2].col))
                     sum=a[n-1].t;
                }
                vis=sum;
                sum/=2;
                memset(f,0,sizeof(f));
              for(j=t;j<i;j++){
                for(k=sum;k>=a[j].t;k--){
                    f[k]=max(f[k],f[k-a[j].t]+a[j].t);
                }
              }
              res=0;
              for(j=0;j<=sum;j++)
                res=max(res,f[j]);
              ans+=(vis-res);
              //cout<<vis-res<<endl;
              sum=0;
              t=i;
            }
            sum+=a[i].t;
        }
        cout<<ans<<endl;
    }
    return 0;
}

某学长的0ms做法。。http://blog.csdn.net/fp_hzq/article/details/6834271
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值