UVA 11584 Partitioning by Palindromes 回文串dp

Partitioning by Palindromes
Time Limit:1000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

Download as PDF

Problem H: Partitioning by Palindromes

Can you read upside-down?

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int INF=1e9;

int vis[1111][1111];

int main()
{
    int n;
    cin>>n;
    char str[1111];
    int f[1111];
    while(n--)
    {
        int len,i,j;
        memset(f,0,sizeof(f));
        memset(vis,0,sizeof(vis));
        scanf("%s",str+1);
        len=strlen(str+1);
        for(i=1;i<=len;i++)
        {
            vis[i][i]=1;
            if(str[i]==str[i+1]&&i+1<=len)  vis[i][i+1]=1;

        }
        for(i=1;i<=len;i++)
        {
            for(j=1;j+i<=len;j++)
            {
                if(str[j]==str[j+i]&&vis[j+1][j+i-1])
                    vis[j][j+i]=1;
            }
        }
        /*for(i=1;i<=len;i++)
        {
            for(j=1;j<=len;j++)
            {
                cout<<vis[i][j]<<" ";
            }
            cout<<endl;
        }*/
        f[0]=0;
        for(i=1;i<=len;i++)
            f[i]=INF;
        for(i=1;i<=len;i++)
        {
            for(j=1;j<=i;j++)
            {
                if(vis[j][i])
                    f[i]=min(f[i],f[j-1]+1);
            }
        }
        cout<<f[len]<<endl;


    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值