NEFU474 The Perfect StallHal Burch 二分图最大匹配

The Perfect StallHal Burch

Time Limit 1000ms

Memory Limit 65536K

description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

							

input

Input file contains multiple test cases. 
In a test case:
Line 1:	One line with two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn.
Line 2..N+1:	N lines, each corresponding to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si<= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

							

output

For each case,A single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

							

sample_input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
							

sample_output

4

							

hint


								
							

source

USACO 4.2


Dinic模板题,主要是建立模型



有了源点和汇点,源点到左边每个的流量都是1,也就是只能通过1 次,汇点也类似,而左边的点到右的点对应的边的边容量为1,就这样,这道题成功转换为最大流问题,建图后最大流解决



#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

const int INF=1e9;

const int mm=1e5;

const int mn=444;

int node,s,t,edge;

int ver[mm],flow[mm],next[mm];

int head[mn],work[mn],dis[mn],q[mn];

void init(int _node,int _s,int _t)
{
    node=_node, s=_s, t=_t;
    for(int i=0;i<node;++i)
        head[i]=-1;
    edge=0;
}


void addedge(int u,int v,int c)
{
    ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}


bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0;i<node;++i)  dis[i]=-1;
    dis[ q[r++]=s ] = 0;
    for(l=0;l<r;l++)
    {
        for(i=head[ u=q[l] ]; ~i ;i=next[i])
            if(flow[i] && dis[ v=ver[i] ]<0)
             {
                 dis[ q[r++]=v ]=dis[u]+1;
                 if(v==t) return 1;
             }
    }
    return 0;
}

int Dinic_dfs(int u,int exp)
{
    if(u==t) return exp;
    for(int &i=work[u],v,temp; ~i ;i=next[i])
    {
        if(flow[i] && dis[ v=ver[i] ]==dis[u]+1 && ( temp=Dinic_dfs(v,min(exp,flow[i])) )>0)
        {
            flow[i]-=temp;
            flow[i^1]+=temp;
            return temp;
        }
    }
    return 0;
}

int Dinic_flow()
{
    int ans=0,res,i;
    while(Dinic_bfs())
    {
        for(i=0;i<node;++i) work[i]=head[i];
        while( res=Dinic_dfs(s,INF) )  ans+=res;
    }
    return ans;
}


int main()
{
    int n,m,u,v,c;
    while(~scanf("%d%d",&n,&m))
    {
        init(n+m+2,0,n+m+1);
        for(u=1;u<=n;u++)
        {
            addedge(s,u,1);
            scanf("%d",&c);
            while(c--)
            {
                scanf("%d",&v);
                addedge(u,n+v,1);
            }
        }
        while(m)
            addedge(n+m--,t,1);
        printf("%d\n",Dinic_flow());
    }
}


二分图最大匹配相关算法:匈牙利算法、Hopcroft-Karp 算法

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值