UVALive 5881 Unique Encryption Keys

Time Limit: 30000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

Download as PDF

The security of many ciphers strongly depends on the fact that the keys are unique and never re-used. This may be vitally important, since a relatively strong cipher may be broken if the same key is used to encrypt several different messages.

In this problem, we will try to detect repeating (duplicate) usage of keys. Given a sequence of keys used to encrypt messages, your task is to determine what keys have been used repeatedly in some specified period.

Input

The input contains several cipher descriptions. Each description starts with one line containing two integer numbers M and Q separated by a space. M(1$ \le$M$ \le$1000000) is the number of encrypted messages, Q is the number of queries (0$ \le$Q$ \le$1000000).

Each of the following M lines contains one number Ki(0$ \le$Ki$ \le$230) specifying the identifier of a key used to encrypt the i-th message. The next Q lines then contain one query each. Each query is specified by two integer numbers Bj and Ej1$ \le$Bj$ \le$Ej$ \le$M, giving the interval of messages we want to check.

There is one empty line after each description. The input is terminated by a line containing two zeros in place of the numbers M and Q.

Output

For each query, print one line of output. The line should contain the string ``OK" if all keys used to encrypt messages between Bj and Ej (inclusive) are mutually different (that means, they have different identifiers). If some of the keys have been used repeatedly, print one identifier of any such key.

Print one empty line after each cipher description.

Sample Input

10 5
3
2
3
4
9
7
3
8
4
1
1 3
2 6
4 10
3 7
2 6

5 2
1
2
3
1
2
2 4
1 5

0 0

Sample Output

3
OK
4
3
OK

OK
1

#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>

using namespace std;

#define PB push_back
#define MP make_pair
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define MAX3(a,b,c) max(a,max(b,c))
#define MAX4(a,b,c,d) max(max(a,b),max(c,d))
#define MIN3(a,b,c) min(a,min(b,c))
#define MIN4(a,b,c,d) min(min(a,b),min(c,d))
#define PI acos(-1.0)
#define INF 0x7FFFFFFF
#define LINF 1000000000000000000LL
#define eps 1e-8

typedef long long ll;
typedef unsigned long long ull;

const int maxn=1e6+100;
int n,m;
int a[maxn];
int b[maxn];

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(!n && !m) break;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        map<int ,int > p;
        p.clear();
        CLR(b);
        for(int i=n-1;i>=0;i--)
        {
            b[i]=INF;
            if(i<n-1) b[i]=b[i+1];
            if(p.find(a[i])!=p.end())
                b[i]=min(b[i],p[a[i]]);
            p[a[i]]=i;
        }
        int l,r;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&l,&r);
            l--,r--;
            if(b[l]<=r)
                printf("%d\n",a[b[l]]);
            else
                printf("OK\n");
        }
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值