Problem 2137 奇异字符串
Accept: 60 Submit: 240
Time Limit: 1000 mSec Memory Limit : 32768 KB
Problem Description
seen喜欢一种特殊的字符串,seen称这种字符串为奇异字符串。奇异字符串可以表示为AxA这种形式,A为一个任意非空字符串,只包含小写字母,x为一个不在A中出现过的小写字母。seen认为一个长度为d的奇异字符串的价值为d*d,不是奇异字符串的字符串没有价值。现给一个只包含小写字母的字符串,统计其所有子串的价值总和。一个字符串的子串是指其中连续的一段字符构成的字符串。这里相同的子串如果在原串中出现的位置不同则视为不同,需要分别进行统计。
Input
第一行一个整数T,表示有T组数据。
每组数据输入一行只包含小写字母的非空字符串,长度不超过100000。
Output
对于每组数据输出一行表示所有子串的价值总和。
Sample Input
1abcdabc
Sample Output
49
字符串哈希搞搞。。
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <bitset>
using namespace std;
#define PB push_back
#define MP make_pair
#define REP(i,n) for(int i=0;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define DWN(i,h,l) for(int i=(h);i>=(l);--i)
#define CLR(vis,pos) memset(vis,pos,sizeof(vis))
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LINF 1000000000000000000LL
typedef unsigned long long ull;
const int maxn=100000+100;
ull seed=131;
ull nhash[maxn],nbase[maxn];
char s[maxn];
void init(int len){
nhash[0]=0,nbase[0]=1;
FOR(i,1,len){
nhash[i]=nhash[i-1]*seed+s[i];
nbase[i]=nbase[i-1]*seed;
}
}
ull gethash(ull l,ull r){
return nhash[r]-nhash[l-1]*nbase[r-l+1];
}
int main ()
{
int _;
cin>>_;
REP(casnum,_){
scanf("%s",s+1);
int len=strlen(s+1);
init(len);
ull ans=0;
for(int i=2;i<len;i++){
ull l=i-1,r=i+1;
while(l<=r){
if(s[l]==s[i] || s[r]==s[i]) break;
if(gethash(l,i-1)==gethash(i+1,r))
ans+=(ull)(r-l+1)*(r-l+1);
l--,r++;
}
}
cout<<ans<<endl;
}
return 0;
}