1068. Find More Coins

1068. Find More Coins (30)

时间限制
150 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution


题意:

给定一系列的硬币值, 然后给定一个目标value, 从所有硬币中找出几个, 使得这几个硬币的和正好等于这个value, 而且这个硬币序列应该是满足硬币值字典序的最小序列.

分析:

属于典型的背包问题.  用动态规划(dp)做, 假设F(N, M)表示不超过面值M, 而且从前面N个硬币中挑选硬币值能得到的最大硬币面值总和, 那我们可以得到如下递归公式:

F(N, M) = max{ F(N–1, M), F(N–1, M–c(N)) + c(N) },c(N)表示第N个硬币的面值

那么最后要是F(N, M)  == M, 那么就说明我们可以找到这样一组硬币, 使得他们的面值总和恰好等于M。 

记录路径:若has(N, M)为真, 则表示从前面N个硬币中选出一组得到最多的不超过M的币值总和里面包括了第N个硬币。那么如果我们需要找到完整路径, 我们就可以从N、M出发,一直回溯到最后一个硬币。

代码:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

#define MAXTOTAL	10001
#define MAXAMOUNT	101

int f[MAXTOTAL][MAXAMOUNT];			//f[n][m]表示 前n个数中 得出的 最接近m 的值
bool has[MAXTOTAL][MAXAMOUNT];		//has[n][m]表示在前n个数中得出最接近m的值时 是否用到c[n]
int* c = NULL;

int calcClosestSum(int n, int m)
{
	memset(f, 0, sizeof(int)*MAXTOTAL*MAXAMOUNT);
	memset(has, false, sizeof(bool)*MAXTOTAL*MAXAMOUNT);
	int i, j;
	int sec;
	for (i = 1; i<n + 1; i++)
	{
		for (j = 1; j <= m; j++)
		{
			if (j - c[i]<0)sec = 0;//最小面值的钱都比需要支付的钱多
			else sec = f[i - 1][j - c[i]] + c[i];//从前面i-1个选最接近j-c[i]的值+c[i]
			if (f[i - 1][j] > sec)//不加入c[i]
			{
				f[i][j] = f[i - 1][j];
			}
			else
			{
				f[i][j] = sec;
				has[i][j] = true;		//用到c[i]了 设has[i][j]为true
			}
		}
	}
	return f[n][m];
}

bool cmp(const int& A, const int& B)
{
	return A>B;
}

int main()
{
	int n, m;
	cin >> n >> m;
	c = new int[n + 1];
	memset(c, 0, sizeof(int)*(n + 1));

	int i;
	for (i = 0; i<n; i++)
	{
		cin >> c[i + 1];
	}
	sort(&c[1], &c[n + 1], cmp);		//从大到小排序

	int res = calcClosestSum(n, m);
	if (res == m)					//有解
	{
		vector<int> v;
		while (m)
		{
			while (!has[n][m])
				n--;
			v.push_back(c[n]);
			m = m - c[n];
			n--;
		}
		for (i = 0; i<v.size() - 1; i++)
			cout << v[i] << ' ';
		cout << v[i] << endl;
	}
	else						//无解
		cout << "No Solution" << endl;
	system("PAUSE");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值