Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5767    Accepted Submission(s): 1073


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Source
CHEN, Shunbao
 Recommend
JGShining

 第一眼看还以为要用动态规划,在看发现A,B不确定而且n太大了,才知道要找规律,列出些数字后发现是有循环的,7*7=49就会出现一次,一开始还以为所有循环都是以1,1开头的,结果错了,不一定都是以1,1循环的,如293,210 i=(1,2,3,4.............)再重新改了N久,终于AC了,写的好辛苦~~~~~~

 

#include < stdio.h >
int  main()
{
    
int  a,b,n;
    
while (scanf( " %d %d %d " , & a, & b, & n) != EOF && (a + b + n) != 0 ){
        
int  f1 = 1 ,f2 = 1 ,f3 = 1 ,t,r[ 8 ][ 8 ] = { 0 },i,flag = 0 ,x;
        
for (i = 3 ;i <= n;i ++ ){
            f3
= (a * f2 + b * f1) % 7 ;
            r[f1][f2]
= i;
            f1
= f2;
            f2
= f3;
            
if (r[f1][f2] && flag == 0 ){ // f1,f2再次出现
                t = i - r[f1][f2] + 1 ; // 算出周期
                i = r[f1][f2] - 3 ; // 最早周期出现处
                n = (n - i) % t + i; // 算出n在第一个周期的位置
                 if (n == i) // n为周期的最后一个数
                    n = t + i;
                
if (n == (i + 1 )) {f3 = f1; break ;} // 刚好是周期开始的那2个数
                 if (n == (i + 2 )) {f3 = f2; break ;}
                i
+= 2 ; // 使和第一次情况吻合
                flag = 1 ;
            }
        }
        printf(
" %d " ,f3);
    }
    
return   0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值