UVa 1395 Slim Span

Given an undirected weighted graph G , you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE) , where V is a set of vertices {v1v2,..., vn} and E is a set of undirected edges {e1e2,..., em} . Each edge e $ \in$ E has its weight w(e) .

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n - 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n - 1 edges of T .

\epsfbox{p3887a.eps}

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5} . The weights of the edges are w(e1) = 3 , w(e2) = 5 , w(e3) = 6 , w(e4) = 6 , w(e5) = 7 as shown in Figure 5(b).

=6in  \epsfbox{p3887b.eps}

There are several spanning trees for G . Four of them are depicted in Figure 6(a)∼(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb , Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input 

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.


n m 
a1 b1 w1 
$ \vdots$ 
am bm wm 


Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.


n is the number of the vertices and m the number of the edges. You can assume 2$ \le$n$ \le$100 and 0$ \le$m$ \le$n(n - 1)/2 . ak and bk (k = 1,...,m) are positive integers less than or equal to n , which represent the two vertices vak and vbk connected by the k -th edge ek . wk is a positive integer less than or equal to 10000, which indicates the weight of ek . You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output 

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, `-1' should be printed. An output should not contain extra characters.

Sample Input 

4 5 
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6 
1 2 10 
1 3 100 
1 4 90 
2 3 20 
2 4 80 
3 4 40 
2 1 
1 2 1
3 0 
3 1 
1 2 1
3 3 
1 2 2
2 3 5 
1 3 6 
5 10 
1 2 110 
1 3 120 
1 4 130 
1 5 120 
2 3 110 
2 4 120 
2 5 130 
3 4 120 
3 5 110 
4 5 120 
5 10 
1 2 9384 
1 3 887 
1 4 2778 
1 5 6916 
2 3 7794 
2 4 8336 
2 5 5387 
3 4 493 
3 5 6650 
4 5 1422 
5 8 
1 2 1 
2 3 100 
3 4 100 
4 5 100 
1 5 50 
2 5 50 
3 5 50 
4 1 150 
0 0

Sample Output 

1 
20 
0 
-1 
-1 
1 
0 
1686 
50
 
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

// 边的结构体
typedef struct e_node
{
	int a, b;	// 边的端点
	int w;		// 边的权重
	bool operator < (const struct e_node& x) const
	{
		return w < x.w;
	}
}e_node;

vector<e_node> e_array;

// p[i]代表结点i所在连通分量的父节点
// p[i]==i代表结点i为所在连通分量的树根
int p[120];

int n, m;

int inf = (1<<30);


int find(int x);


int main()
{
	while(scanf("%d %d", &n, &m) == 2 && !(n == 0 && m == 0))
	{
		// 读入所有边
		e_array = vector<e_node>();
		for(int i = 1; i <= m; i++)
		{
			e_node x;
			scanf("%d %d %d", &x.a, &x.b, &x.w);
			e_array.push_back(x);
		}

		// 将所有边按权重从小到大排序
		sort(e_array.begin(), e_array.end());

/*
		for(int i = 0; i < m; i++)
			printf("a:%d b:%d w:%d\n", e_array[i].a, e_array[i].b, e_array[i].w);
*/

		// 枚举所有可能情况的最小生成树
		int result = inf;
		for(int i = 0; i < m; i++)
		{
			// 将所有点作为单独连通分量
			for(int j = 1; j <= n; j++)
				p[j] = j;
			int c_count = n;
			// 建立最小生成树
			for(int j = i; j < m; j++)	
			{
				// 查看该边的两个端点是否在一个连通分量中
				// 如果不是,将该边加入生成树
				// 即将该两点所在连通分量合并
				int f_a = find(e_array[j].a);
				int f_b = find(e_array[j].b);

				if(f_a != f_b)
				{
					c_count--;
					p[f_a] = f_b;
					if(c_count == 1)
					{
						result = min(result, e_array[j].w-e_array[i].w);
		//				printf("here: result %d\n", result);
						break;
					}
				}	
			}			
		}				

		if(result == inf)
			printf("-1\n");
		else
			printf("%d\n", result);	
	}	
	return 0;	
}

// 找到该节点的连通分量代表元素
int find(int x)
{
	if(p[x] == x)
		return x;
	else
	{
		int f_x = find(p[x]);
		p[x] = f_x;
		return f_x;	
	}
}


这是道好题,想着用Kruskal求最小生成树框架思路,但是这里求的是最大最小权重差值最小的生成树。
想到枚举最小权重的边,来看最大权重的情况,但是最小生成树只是保证权重之和最小,如果保证最大权重最小。
后来发现一条性质:最小生成树不仅权重之和最小,而且最大权重最小。
即:最小生成树为瓶颈生成树。证明可以在网上找。
这样,就可以枚举最小权重,来生成最小生成树,这样得到的就为该最小权重下的最大最小权重差值最小的生成树。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
校园悬赏任务平台对字典管理、论坛管理、任务资讯任务资讯公告管理、接取用户管理、任务管理、任务咨询管理、任务收藏管理、任务评价管理、任务订单管理、发布用户管理、管理员管理等进行集中化处理。经过前面自己查阅的网络知识,加上自己在学校课堂上学习的知识,决定开发系统选择小程序模式这种高效率的模式完成系统功能开发。这种模式让操作员基于浏览器的方式进行网站访问,采用的主流的Java语言这种面向对象的语言进行校园悬赏任务平台程序的开发,在数据库的选择上面,选择功能强大的Mysql数据库进行数据的存放操作。校园悬赏任务平台的开发让用户查看任务信息变得容易,让管理员高效管理任务信息。 校园悬赏任务平台具有管理员角色,用户角色,这几个操作权限。 校园悬赏任务平台针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理任务信息,管理任务资讯公告信息等内容。 校园悬赏任务平台针对用户设置的功能有:查看并修改个人信息,查看任务信息,查看任务资讯公告信息等内容。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。项目管理页面提供的功能操作有:查看任务,删除任务操作,新增任务操作,修改任务操作。任务资讯公告信息管理页面提供的功能操作有:新增任务资讯公告,修改任务资讯公告,删除任务资讯公告操作。任务资讯公告类型管理页面显示所有任务资讯公告类型,在此页面既可以让管理员添加新的任务资讯公告信息类型,也能对已有的任务资讯公告类型信息执行编辑更新,失效的任务资讯公告类型信息也能让管理员快速删除。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值