POJ1986Distance Queries(双向带权LCA)

Farmer John's cows refused to run in his marathon since he chose a path much too long for their leisurely lifestyle. He therefore wants to find a path of a more reasonable length. The input to this problem consists of the same input as in "Navigation Nightmare",followed by a line containing a single integer K, followed by K "distance queries". Each distance query is a line of input containing two integers, giving the numbers of two farms between which FJ is interested in computing distance (measured in the length of the roads along the path between the two farms). Please answer FJ's distance queries as quickly as possible!
Input
* Lines 1..1+M: Same format as "Navigation Nightmare"

* Line 2+M: A single integer, K. 1 <= K <= 10,000

* Lines 3+M..2+M+K: Each line corresponds to a distance query and contains the indices of two farms.
Output
* Lines 1..K: For each distance query, output on a single line an integer giving the appropriate distance.
Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6
1 4
2 6
Sample Output
13
3
36
Hint
Farms 2 and 6 are 20+3+13=36 apart.

题意:一棵带权树,n个节点,m条边的信息,然后是k个询问查询两点间距离。例如1点到6点距离是13,最后字母是方向不过没啥用

两点连通一定经过祖先,距离为根节点到两点的距离和-2*根节点到祖先的距离

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define N 40002
using namespace std;
vector<pair<int,int> >q[N],que[N];
int vis[N],par[N],dist[N],n,ans[10003];
int F(int x)
{
    return x==par[x]?x:par[x]=F(par[x]);
}
void LCA(int rf,int fa)
{
    int i;
    par[rf]=rf;
    for(i=0; i<q[rf].size(); i++)
    {
        int v=q[rf][i].first;
        if(v==fa) continue;//因为双向,所以一定会进这个循环,此过程避免重复循环
        dist[v]=dist[rf]+q[rf][i].second;
        LCA(v,rf);
        par[v]=rf;
    }
    vis[rf]=1;
    for(i=0; i<que[rf].size(); i++)
    {
        int v=que[rf][i].first;
        if(vis[v])
        {
            ans[que[rf][i].second]=dist[rf]+dist[v]-2*dist[F(v)];
        }
    }
}
int main()
{
    int m,i,a,b,d;
    char c;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=1; i<=n; i++)
        {
            vis[i]=dist[i]=ans[i]=0;
            q[i].clear();
            que[i].clear();
        }
        while(m--)
        {
            scanf("%d%d%d %c",&a,&b,&d,&c);
            q[a].push_back(make_pair(b,d));
            q[b].push_back(make_pair(a,d));
        }
        scanf("%d",&m);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            que[a].push_back(make_pair(b,i));//i作为输出次序保存下来
            que[b].push_back(make_pair(a,i));
        }
        dist[1]=0;
        LCA(1,0);//以1为根节点;因为双向,所以一定得把父亲节点写上
        for(i=1; i<=m; i++)//顺序输出
            printf("%d\n",ans[i]);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值