hdu3336—Count the string(kmp+dp)

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11169    Accepted Submission(s): 5207


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1
4
abab
 

Sample Output
  
  
6
 

Author
foreverlin@HNU
 

Source
 

Recommend
lcy
 

Statistic |  Submit |  Discuss | Note

题意:求一个字符串所有前缀的数量和并mod10007
思路:利用Next数组:前i个字符所组成的字符串的最大前后缀匹配长度的性质,dp[i]=dp[Next[i-1]]+1,dp[i]是以i结尾的字符串数量,由Next可知此字符串也一定是前缀,+1即本身,所有前缀和等于所有的dp[i]相加,总之比较难理解。

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 200005
using namespace std;
int Next[N],dp[N];//以i结尾的前缀总数
char s[N];
void getnext(int n)
{
    int i,j;
    for(i=1,j=0; i<n; i++)
    {
        while(s[j]!=s[i]&&j>0)
            j=Next[j-1];
        if(s[i]==s[j])
            j++;
        Next[i]=j;
    }
}
int main()
{
    int t,n,i;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=1; i<=n; i++)
            dp[i]=0;
        scanf("%s",s);
        getnext(n);
        int num=0;
        for(i=1; i<=n; i++)
        {
            dp[i]=dp[Next[i-1]]+1;
            num=(num+dp[i])%10007;
        }
        printf("%d\n",num);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值