poj3041—Asteroids(最小点覆盖)

传送门:点我

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

大意:

输入N,k,表示在N*N的地图中有k个陨石,以下k行是陨石的横纵坐标,开一枪能让一排或一列的陨石消失,求最少开几枪能让所有陨石消失。

思路:x,y坐标相连可看成一条边,让所有的坐标都消失,转化为让所有边消失,即最小顶点覆盖数=最大匹配数

上马:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
#define N 510
vector<int>q[N];
int match[N];
bool vis[N];
bool hungary(int u)
{
    int i;
    for(i=0; i<q[u].size(); i++)
    {
        int v=q[u][i];
        if(!vis[v])
        {
            vis[v]=1;
            if(!match[v]||hungary(match[v]))
            {
                match[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int n,k,i;
    while(~scanf("%d%d",&n,&k))
    {
        for(i=1; i<=n; i++)
            q[i].clear();
        int a,b;
        for(i=1; i<=k; i++)
        {
            scanf("%d%d",&a,&b);
            q[a].push_back(b);
        }
        memset(match,0,sizeof(match));
        int ans=0;
        for(i=1; i<=n; i++)
        {
            memset(vis,0,sizeof(vis));
            ans+=hungary(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值