HDU - 1002 A + B Problem II

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 452860 Accepted Submission(s): 87794

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

问题分析:
1)与一般的A+B问题不同,题目中每个整数的位数不超过1000,就算是long long int也不够。
2)用高精度算法,设置两个字符数组来存储两个需要相加的数。
3)用另外两个整型数组来将字符在去掉前导零的情况下,进行倒序存储
4)设置另一整型数组然后将两个整形数组的每一位数两两相加,并注意处理好进位
5)将存储总和的数组进行倒序输出
6)每一次相加之后对各个数组进行置零,未免影响下一个例子。

已AC的代码如下:

#include<iostream>
#include<cstring>
#define max(a,b)    (((a) > (b)) ? (a) : (b))
using namespace std;

struct hugeint
{
	int num[1001];
	int len;
};
hugeint a, b, s;
char c[1001], d[1001];

void scan()
{
	
	cin >> c>> d;
	a.len = strlen(c);
	b.len = strlen(d);
	for (int i = 0;i < 1001;i++)	a.num[i] = 0;
	for (int i = 0;i < 1001;i++)	b.num[i] = 0;
	for (int i = 0;i < a.len;i++)   a.num[a.len - i] = c[i] - '0';
	for (int i = 0;i < b.len;i++)	b.num[b.len - i] = d[i] - '0';
}

void Plus()
{
	s.len = max(a.len, b.len);
	
	for (int i = 1;i <= s.len;i++)
	{
		s.num[i] += a.num[i] + b.num[i];
		s.num[i + 1] += s.num[i] / 10;
		s.num[i] %= 10;	
	}
	if (s.num[s.len + 1] != 0)
		s.len++;
}

int main()
{
	int n, j = 1;
	cin >> n;
	while (n--)
	{
		scan();
		Plus();
		cout << "Case " << j++ << ":" << endl;
		
			cout << c;
		cout << " " << "+" << " ";
		
			cout << d;
		cout << " " << "=" << " ";
		for (int i = s.len;i >= 1;i--)
			cout << s.num[i];
		cout << endl;	
		if (n)	cout << endl;
		for (int i = 1;i <= 1001;i++)	s.num[i] = 0;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值