最小生成树(Krushal算法)

个人认为如果学过并查集的话,Krushal要比prim好用点,基本看到就会的那种

下面用poj1251这道题来入门学习一下

题目描述

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
在这里插入图片描述

input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

ouput

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题目大意

每两个点之间有n条路径,每条路径的费用不一样,要选择最少费用的路径能连通所有的点
求最少的费用的多少?

Krushal算法核心的思想就是将每条边储存起来,可以PriorityQueue来储存,将每条边按从小到大的顺序取出,用并查集判断这两个点有没有连通,如果没有,就将这两个点连通为一个集合,记录下边的价格;如果连通了,就跳过,不处理。

下面是代码,很简单

import java.util.PriorityQueue;
import java.util.Queue;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);
		
		while(true) {
			
			par = null;
			rank = null;
			
			int n = sc.nextInt();
			
			if(n == 0) break;
			
			sc.nextLine();
			
			build(n);
			
			Queue<edge> que = new PriorityQueue<edge>();
			
			for(int i = 0; i < n - 1; i++) {
				
				String[] cs = sc.nextLine().split(" ");
				
				int root = cs[0].charAt(0) - 'A';   //将字母转换为数字
				int num = Integer.parseInt(cs[1]); 
				
				for(int j = 1; j <= num; j++) {
					int road = cs[j * 2].charAt(0) - 'A';
					int cost = Integer.parseInt(cs[j * 2 + 1] + "");
					
					edge e = new edge();
					e.e1 = root;
					e.e2 = road;
					e.cost = cost;
					que.offer(e);
					
				}
				
			}
			
			int result = 0;
			
			while(!que.isEmpty()) {
				edge e = que.poll();
				if(!isSame(e.e1, e.e2)) {
					unite(e.e1, e.e2);
					result += e.cost;
				}
			}
			
			System.out.println(result);
			
		}
		
	}
	/**
	并查集实现
	**/
	static int [] par;
	static int [] rank;
	
	public static void build(int n) {
		
		par = new int [n];
		rank = new int [n];
		
		for(int i = 0; i < n; i++) {
			par[i] = i;
			rank[i] = 0;
		}
		
	}

	public static int find(int x) {
		
		if(par[x] == x) {
			return x;
		}else {
			return par[x] = find(par[x]);
		}
		
	}
	
	public static boolean isSame(int x, int y) {
		return find(x) == find(y);
	}
	
	public static void unite(int x, int y) {
		
		x = find(x);
		y = find(y);
		
		if(x == y) return;
		
		if(rank[x] < rank[y]) {
			par[x] = y;
		}else {
			par[y] = x;
			if(rank[x] == rank[y]) rank[x]++;
		}
		
		
	}

}
//用一个类代表一条边
class edge implements Comparable<edge>{
	
	int e1, e2, cost;

	@Override
	public String toString() {
		return "edge [e1=" + e1 + ", e2=" + e2 + ", cost=" + cost + "]";
	}

	@Override
	public int compareTo(edge o) {
		return this.cost - o.cost;
	}
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值