hdu 4268 Alice and Bob(2012 ACM/ICPC Asia Regional Changchun Online 12年长春网络赛)

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2690    Accepted Submission(s): 865


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

Source
 


贪心,就是取b[i].h小于等于a[i].h中,取能取到的b中最大的w。


代码:


//time 703ms
#include <iostream>
#include<set>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=100000+100;
struct node
{
    int h;
    int w;

}a[maxn],b[maxn];
multiset<int> s;
multiset<int>::iterator it;
bool cmp(node a,node b)
{
   // if(a.h==b.h)
  //  return a.w<b.w;
    return a.h<b.h;//只排一维即可,排二维完全没必要,因为第二维用不到
}

int S()
{
    int ret=0,ok=0;
    char c;
    while((c=getchar()))
    {
        if(c>='0'&&c<='9')
        ret=(ret<<3)+ret+ret+c-'0',ok=1;
        else if(ok)
        return ret;
    }
    return ret;
}

int main()
{
    int t=S();//读入优化,其实完全没必要
    int n,ans;
    while(t--)
    {
        s.clear();
        ans=0;
        n=S();
        for(int i=0;i<n;i++)
        {
           a[i].h=S();
           a[i].w=S();
          //printf("%d\n")
           // scanf("%d%d",&a[i].h,&a[i].w);
        }
        for(int i=0;i<n;i++)
        {
            b[i].h=S();
            b[i].w=S();
           // scanf("%d%d",&b[i].h,&b[i].w);
        }
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        int k=0;
        int x,y;
        for(int i=0;i<n;i++)//将比b中的h小于等于a[i].h的放进set里
        {
            x=a[i].h;
            y=a[i].w;
            for(int j=k;j<n;j++)
            {
                if(b[j].h<=x)
                {
                    s.insert(b[j].w);
                    k++;
                }
                else
                break;//忘记及时跳出,一直T
            }
            if(s.size())
            {
            it=s.upper_bound(y);
            if(it!=s.begin())
            {
              it--;
              s.erase(it);
              ans++;
            }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值